Bug 19621 - "Passwort bei der nächsten Anmeldung ändern" Synchronisation (POSIX/Kerberos)
"Passwort bei der nächsten Anmeldung ändern" Synchronisation (POSIX/Kerberos)
Status: RESOLVED WONTFIX
Product: UCS
Classification: Unclassified
Component: AD Connector
UCS 2.4
Other Linux
: P5 normal (vote)
: UCS 4.2-x
Assigned To: Connector maintainers
:
: 3499 11054 13778 22931 (view as bug list)
Depends on: 14209
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-24 15:43 CEST by Stefan Gohmann
Modified: 2017-11-20 18:05 CET (History)
6 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 5: Major Usability: Impairs usability in key scenarios
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 3: A User would likely not purchase the product
User Pain: 0.171
Enterprise Customer affected?: Yes
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number: 2017111721000181
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2010-08-24 15:43:14 CEST
Das Verhalten der Passwortablaufdaten scheint nicht einheitlich synchronisiert zu werden.

Nachdem ich unter Windows 2000, 2003 und 2008R2 bei den Benutzern das Flag Passwort bei der nächsten Anmeldung ändern gesetzt hatte, konnte ich mich problemlos auf den UCS-Systemen per GDM anmelden.

Auf dem UCS-System, welches mit dem Windows 2008R2 verbunden ist, bekam ich beim smbclient die Meldung NT_STATUS_PASSWORD_MUST_CHANGE. Bei Windows 2000 und Windows 2003 war die smbclient-Anmeldung problemlos.
Comment 1 Stefan Gohmann univentionstaff 2010-09-28 07:34:51 CEST
Grundsätzlich scheint das Problem zu sein, dass wir lediglich die Samba Ablaufdaten synchronisieren. Besser wäre es, wenn wir die Ablaufdaten für Posix und Kerberos ebenfalls setzen, wenn im AD die Ablaufdaten gesetzt werden.
Comment 2 Stefan Gohmann univentionstaff 2010-09-28 08:48:31 CEST
(In reply to comment #1)
> Grundsätzlich scheint das Problem zu sein, dass wir lediglich die Samba
> Ablaufdaten synchronisieren. Besser wäre es, wenn wir die Ablaufdaten für Posix
> und Kerberos ebenfalls setzen, wenn im AD die Ablaufdaten gesetzt werden.

Die Unterstützung dafür bietet das UDM-Modul für Benutzer derzeit leider nicht: Bug #14209

Sobald das umgesetzt ist, sollte auch dieses Verhalten angepasst werden.

(In reply to comment #0)
> Auf dem UCS-System, welches mit dem Windows 2008R2 verbunden ist, bekam ich
> beim smbclient die Meldung NT_STATUS_PASSWORD_MUST_CHANGE. Bei Windows 2000 und
> Windows 2003 war die smbclient-Anmeldung problemlos.

Das funktioniert mittlerweile.
Comment 3 Stefan Gohmann univentionstaff 2010-11-12 10:26:36 CET
*** Bug 3499 has been marked as a duplicate of this bug. ***
Comment 4 Stefan Gohmann univentionstaff 2011-06-29 06:54:14 CEST
*** Bug 13778 has been marked as a duplicate of this bug. ***
Comment 5 Stefan Gohmann univentionstaff 2011-06-29 06:55:05 CEST
*** Bug 11054 has been marked as a duplicate of this bug. ***
Comment 6 Sönke Schwardt-Krummrich univentionstaff 2011-06-29 10:51:29 CEST
*** Bug 22931 has been marked as a duplicate of this bug. ***
Comment 7 Sönke Schwardt-Krummrich univentionstaff 2011-06-29 10:52:48 CEST
In 22931 ist ein entsprechendes Szenario in Verbindung mit unidirektionalem Write (UCS-->AD) in Verbindung mit dem Passwort-Sync-Daemon beschrieben.
Comment 8 Stefan Gohmann univentionstaff 2011-10-06 13:50:01 CEST
Sollte nach dem 3.0 Release nochmal geprüft werden.
Comment 9 Felix Botner univentionstaff 2011-12-05 12:18:35 CET
Das führt u.a. zu folgenden Phänomen:

Im UDM "Change password on next login" am Benutzer gesetzt. Über Windows das Passwort geändert. Auf UCS Seite kann sich der Benutzer am Samba anmelden. Kerberos und Posix verlangen aber wieder einen Passwortwechsel.
Comment 10 Stefan Gohmann univentionstaff 2016-04-25 07:52:27 CEST
This issue has been filed against UCS 2.4.

UCS 2.4 is out of maintenance and many UCS components have vastly changed in
later releases. Thus, this issue is now being closed.

If this issue still occurs in newer UCS versions, please use "Clone this bug".
In this case please provide detailed information on how this issue is affecting
you.