Bug 30489 - flatmode replication should be removed
flatmode replication should be removed
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Listener (univention-directory-listener)
UCS 3.1
Other Linux
: P5 enhancement (vote)
: UCS 4.1-2-errata
Assigned To: Philipp Hahn
Arvid Requate
:
: 30584 33579 (view as bug list)
Depends on:
Blocks: 30584
  Show dependency treegraph
 
Reported: 2013-02-19 11:13 CET by Stefan Gohmann
Modified: 2016-07-21 15:15 CEST (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Cleanup
Max CVSS v3 score:
hahn: Patch_Available+


Attachments
Remove flatmode code (10.82 KB, patch)
2014-04-08 12:29 CEST, Philipp Hahn
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2013-02-19 11:13:00 CET
Currently the replication handler can replicate all users / objects into one single container.
This should be removed from UCS. If someone still need it we should explain, how he could use a own replication handler, dpkg-divert ...
Comment 1 Arvid Requate univentionstaff 2013-11-27 11:13:14 CET
*** Bug 33579 has been marked as a duplicate of this bug. ***
Comment 2 Philipp Hahn univentionstaff 2014-04-08 12:29:02 CEST
Created attachment 5861 [details]
Remove flatmode code

Also remove unused "queue".
Comment 3 Philipp Hahn univentionstaff 2016-06-06 11:51:20 CEST
r69823 | Bug #30489 repl: Remove deprecated "flat-mode" replication

Package: univention-directory-replication
Version: 9.0.1-3.104.201606061133
Branch: ucs_4.1-0
Scope: errata4.1-2

r69841 | Bug #33594,Bug #41347,Bug #28232,Bug #30489,Bug #31757: univention-directory-logger YAML
 univention-directory-replication.yaml
Comment 4 Philipp Hahn univentionstaff 2016-06-06 15:57:09 CEST
*** Bug 30584 has been marked as a duplicate of this bug. ***
Comment 5 Arvid Requate univentionstaff 2016-07-14 21:55:21 CEST
Code review: Ok
Advisory: Ok
Comment 6 Janek Walkenhorst univentionstaff 2016-07-21 15:15:58 CEST
<http://errata.software-univention.de/ucs/4.1/216.html>