Bug 36691 - AD Takeover should depend on Samba4
AD Takeover should depend on Samba4
Status: NEW
Product: UCS
Classification: Unclassified
Component: App Center
UCS 4.2
Other Linux
: P5 normal (vote)
: ---
Assigned To: App Center maintainers
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-14 12:25 CET by Dirk Wiesenthal
Modified: 2017-04-07 11:29 CEST (History)
1 user (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 7: Crash: Bug causes crash or data loss
Who will be affected by this bug?: 1: Will affect a very few installed domains
How will those affected feel about the bug?: 4: A User would return the product
User Pain: 0.160
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Wiesenthal univentionstaff 2014-11-14 12:25:31 CET
AD Takeover has no RequiredApps definition in its ini file. If installed on a plain UCS Master, Samba4 is installed - implicitely.

The problem is: When uninstalling AD Takeover, Samba4 is autoremoved, without any warnings (apart from its name in the package list).

If one would add this to AD Takeover's ini, one may have to rework system-setup's software page, as that does not evaluate any dependencies.

Alternatively, the App Center could always mark installed apps' DefaultPackages as manually installed.