Bug 44185 - Containers of Docker Apps with 4.1-appbox think an update is available, but fail because 4.2 repository does not exist
Containers of Docker Apps with 4.1-appbox think an update is available, but f...
Status: NEW
Product: UCS
Classification: Unclassified
Component: App Center
UCS 4.2
Other Linux
: P5 normal (vote)
: ---
Assigned To: App Center maintainers
App Center maintainers
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-03-31 11:35 CEST by Florian Best
Modified: 2017-04-05 13:48 CEST (History)
1 user (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 5: Major Usability: Impairs usability in key scenarios
Who will be affected by this bug?: 1: Will affect a very few installed domains
How will those affected feel about the bug?: 1: Nuisance – not a big deal but noticeable
User Pain: 0.029
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
updater.log (223.03 KB, text/plain)
2017-03-31 11:35 CEST, Florian Best
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2017-03-31 11:35:41 CEST
Created attachment 8729 [details]
updater.log

root@master431:~# univention-upgrade 

Starting univention-upgrade. Current UCS version is 4.2-0 errata0

Checking for local repository:                          none
Checking for package updates:                           none
Checking for app updates:                               found

The following apps can be upgraded:

Dudle: The underlying container can be upgraded

Starting app upgrade                                   
Do you want to upgrade Dudle [Y|n]? 

                           Dudle 1.1.0-1 Update Notes

Bug fixes

     * Update after some bugfixes.
Press [ENTER] to continue
done
Checking for release updates:                           none
root@master431:~# univention-upgrade 

Starting univention-upgrade. Current UCS version is 4.2-0 errata0

Checking for local repository:                          none
Checking for package updates:                           none
Checking for app updates:                               found

The following apps can be upgraded:

Dudle: The underlying container can be upgraded

Starting app upgrade                                   
Do you want to upgrade Dudle [Y|n]? 

                           Dudle 1.1.0-1 Update Notes

Bug fixes

     * Update after some bugfixes.
Press [ENTER] to continue
done
Checking for release updates:                           none
root@master431:~# echo $?
0
Comment 1 Florian Best univentionstaff 2017-03-31 11:43:26 CEST
CRITICAL:univention.appcenter.actions.upgrade:Unable to process "The update to UCS 4.2 is blocked because the component 'dudle_20160201' is marked as required."
Comment 2 Dirk Wiesenthal univentionstaff 2017-03-31 12:02:53 CEST
This should hold for every appbox App