Bug 47334 - Traceback: univention-app-appliance --only-configure-portal
Traceback: univention-app-appliance --only-configure-portal
Status: NEW
Product: UCS
Classification: Unclassified
Component: App Center
UCS 4.3
Other Linux
: P5 normal (vote)
: ---
Assigned To: App Center maintainers
App Center maintainers
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-07-10 16:03 CEST by Nico Gulden
Modified: 2019-03-15 22:29 CET (History)
1 user (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 3: Simply Wrong: The implementation doesn't match the docu
Who will be affected by this bug?: 1: Will affect a very few installed domains
How will those affected feel about the bug?: 1: Nuisance – not a big deal but noticeable
User Pain: 0.017
Enterprise Customer affected?:
School Customer affected?:
ISV affected?: Yes
Waiting Support:
Ticket number:
Bug group (optional): Appliance
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nico Gulden univentionstaff 2018-07-10 16:03:32 CEST
Testing or updating the branding on a running appliance with univention-app-appliance causes the following traceback:

univention-app-appliance --only-configure-portal onlyoffice-ds
Traceback (most recent call last):
  File "/usr/sbin/univention-app-appliance", line 308, in <module>
    configure_portal(app)
  File "/usr/sbin/univention-app-appliance", line 87, in configure_portal
    result = module.lookup(None, lo, 'cn=domain', base=UCR['ldap/base'], scope='sub')
AttributeError: 'NoneType' object has no attribute 'lookup'

The option --not-configure-portal works though.