Bug 48434 - Etherpad app (etherpad-lite) logs warning about development mode
Etherpad app (etherpad-lite) logs warning about development mode
Status: NEW
Product: UCS
Classification: Unclassified
Component: App Center
UCS 4.3
Other Linux
: P5 normal (vote)
: ---
Assigned To: App Center maintainers
App Center maintainers
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-01-07 14:20 CET by Valentin Heidelberger
Modified: 2019-01-07 14:22 CET (History)
1 user (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 2: Improvement: Would be a product improvement
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 1: Nuisance – not a big deal but noticeable
User Pain: 0.023
Enterprise Customer affected?:
School Customer affected?: Yes
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Valentin Heidelberger univentionstaff 2019-01-07 14:20:45 CET
Out of the box the etherpad app logs the following into its log file (/opt/etherpad-lite/var/etherpad.log in the container):

[WARN] console - Etherpad is running in Development mode. This mode is slower for users and less secure than production mode. You should set the NODE_ENV environment variable to production by using: export NODE_ENV=production

I don't know what slower and less secure means but we probably want to use production mode instead, since the app is available in the prod app center.