Bug 48680 - Apps with required app settings cannot be installed via Console
Apps with required app settings cannot be installed via Console
Status: NEW
Product: UCS
Classification: Unclassified
Component: App Center
UCS 4.3
Other Linux
: P5 normal (vote)
: ---
Assigned To: App Center maintainers
App Center maintainers
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-02-14 13:18 CET by Nico Gulden
Modified: 2019-02-14 13:48 CET (History)
1 user (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 2: Improvement: Would be a product improvement
Who will be affected by this bug?: 3: Will affect average number of installed domains
How will those affected feel about the bug?: 1: Nuisance – not a big deal but noticeable
User Pain: 0.034
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nico Gulden univentionstaff 2019-02-14 13:18:31 CET
When an app uses the App settings and requires a user to enter a value, e.g. to define a password, the installation over Console is not working, because the user is not asked for the data.

During installation at Console, the app installation process should ask the user for the values.
Comment 1 Dirk Wiesenthal univentionstaff 2019-02-14 13:46:48 CET
univention-app install $app --set setting=value
Comment 2 Dirk Wiesenthal univentionstaff 2019-02-14 13:48:27 CET
We do not have an interactive mode, however. Would be nice to have