Bug 18828 - UNIVENTION_JOINSTATUS: Default-Notification-Intervall zu klein
UNIVENTION_JOINSTATUS: Default-Notification-Intervall zu klein
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Nagios
UCS 2.3
Other Linux
: P5 minor (vote)
: UCS 3.1
Assigned To: Felix Botner
Stefan Gohmann
: interim-3
: 16746 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-29 16:45 CEST by Sönke Schwardt-Krummrich
Modified: 2012-12-12 21:08 CET (History)
4 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Flags outvoted (downgraded) after PO Review:
Ticket number:
Bug group (optional):
Max CVSS v3 score:
schwardt: Patch_Available+


Attachments
modify JOIN-Skript replace normalCheckInterval to 180 and retry_check_interval to 10 for UNIVENTION_JOINSTATUS (3.52 KB, patch)
2011-06-29 14:02 CEST, Martin Müller
Details | Diff
modify JOIN-Skript replace normalCheckInterval to 180 and retry_check_interval to 10 for UNIVENTION_JOINSTATUS (3.54 KB, patch)
2011-06-29 14:44 CEST, Martin Müller
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sönke Schwardt-Krummrich univentionstaff 2010-06-29 16:45:28 CEST
Nagios meldet auf der Kommandozeile beim Prüfen seiner Config folgendes:

Warning: Service 'UNIVENTION_JOINSTATUS' on host 'nag24.univention.qa'  has a notification interval less than its check interval!  Notifications are only re-sent after checks are made, so the effective notification interval will be that of the check interval.
Comment 1 Jan Christoph Ebersbach univentionstaff 2010-07-23 08:56:31 CEST
*** Bug 16746 has been marked as a duplicate of this bug. ***
Comment 2 Tobias Scherer univentionstaff 2010-10-01 14:21:09 CEST
ebenso aufgefallen an: Ticket#: 2010093010016972
Comment 3 Martin Müller 2011-06-29 14:02:33 CEST
Created attachment 3368 [details]
modify JOIN-Skript replace normalCheckInterval to 180
and retry_check_interval to 10 for UNIVENTION_JOINSTATUS
Comment 4 Martin Müller 2011-06-29 14:44:47 CEST
Created attachment 3369 [details]
modify JOIN-Skript replace normalCheckInterval to 180 and retry_check_interval to 10 for UNIVENTION_JOINSTATUS
Comment 5 Stefan Gohmann univentionstaff 2012-06-07 14:23:20 CEST
Der Patch sollte übernommen werden, falls das Problem noch auftritt.
Comment 6 Stefan Gohmann univentionstaff 2012-07-17 17:09:59 CEST
UCS 3.1 will be the next release.
Comment 7 Felix Botner univentionstaff 2012-10-31 16:11:22 CET
OK, 

es wird jetzt 

  --set normalCheckInterval="180" --set retryCheckInterval="30"

für UNIVENTION_JOINSTATUS gesetzt.

gesetzt. Falls die vorherige Version kleiner 3 ist (aktuell wurde die Version auf 3 gesetzt) wird das vorhandene UNIVENTION_JOINSTATUS entsprechend angepasst.
Comment 8 Stefan Gohmann univentionstaff 2012-11-15 11:17:50 CET
OK, das funktionierte in meinen Update Tests. Nagios Warnung taucht nicht mehr auf.

Changelog: OK
Comment 9 Stefan Gohmann univentionstaff 2012-12-12 21:08:32 CET
UCS 3.1-0 has been released: 
 http://forum.univention.de/viewtopic.php?f=54&t=2125

If this error occurs again, please use "Clone This Bug".