Bug 22429 - imapd.conf duplicatesuppression per UCR
imapd.conf duplicatesuppression per UCR
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Mail
UCS 2.4
Other Linux
: P5 enhancement (vote)
: UCS 3.2
Assigned To: Liam Schwez
Felix Botner
: interim-1
: 27897 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-05 16:30 CEST by Janis Meybohm
Modified: 2013-11-19 06:44 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Janis Meybohm univentionstaff 2011-05-05 16:30:30 CEST
Für die duplicatesuppression Option der imapd.conf könnte eine UCR Variable eingeführt werden.
Comment 1 Philipp Hahn univentionstaff 2013-04-10 13:00:48 CEST
*** Bug 27897 has been marked as a duplicate of this bug. ***
Comment 2 Liam Schwez univentionstaff 2013-05-07 17:13:25 CEST
UCR variable "mail/cyrus/imap/duplicatesuppression" added. 

File "univention-mail-cyrus.univention-config-registry", "univention-mail-cyrus.postinst" and "univention-mail-cyrus.univention-config-registry-variables" were extended with given UCR variable above. 

File "univention-mail-cyrus.postins/conffiles/etc/imapd/imapd.conf" adjusted fro UCR variable named above. 

If UCR unset the value of duplicatesuppression will be set to a default "1". If set to "yes" duplicatesuppression will be "1". If ucr variable set to "no" duplicatesuppression will be set to "0" in a config file /etc/imapd/imapd.conf.
Comment 3 Moritz Muehlenhoff univentionstaff 2013-05-31 10:44:18 CEST
We will not ship a UCS 3.1-2 release; the next UCS release will be UCS 3.2.

As such, this bug is moved to the new target milestone.
Comment 4 Felix Botner univentionstaff 2013-06-20 12:54:54 CEST
-> /etc/imapd/imapd.conf| grep dupl
mail_cyrus_imap_duplicatesuppression: 1

The option is "duplicatesuppression"
Comment 5 Liam Schwez univentionstaff 2013-06-25 12:08:52 CEST
Set variable to 'duplicatesuppression' instead of 'mail_cyrus_imap_duplicatesuppression' in conffiles/etc/imapd/imapd.conf.
Comment 6 Felix Botner univentionstaff 2013-06-26 11:22:19 CEST
OK
Changelog entry exists
Comment 7 Stefan Gohmann univentionstaff 2013-11-19 06:44:05 CET
UCS 3.2 has been released:
 http://docs.univention.de/release-notes-3.2-en.html
 http://docs.univention.de/release-notes-3.2-de.html

If this error occurs again, please use "Clone This Bug".