Bug 24351 - UMC: Traceback bei Benutzer anlegen mit bestimmter Option
UMC: Traceback bei Benutzer anlegen mit bestimmter Option
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 3.0
Other Linux
: P5 normal (vote)
: UCS 3.1-1-errata
Assigned To: Lukas Walter
Alexander Kläser
:
: 7331 8313 (view as bug list)
Depends on:
Blocks: 26965
  Show dependency treegraph
 
Reported: 2011-11-03 09:45 CET by Florian Best
Modified: 2013-07-10 14:18 CEST (History)
6 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2011-11-03 09:45:56 CET
Wenn ich in UMC einen Benutzer anlege, und unter [Optionen] nur 'Persönliche Informationen' aktiviere bekomme ich diesen Traceback beim erstellen des Benutzers:

File '/usr/lib/pymodules/python2.6/notifier/threads.py', line 81, in _run
tmp = self._function()
File '/usr/lib/pymodules/python2.6/notifier/__init__.py', line 104, in __call__
return self._function( *tmp, **self._kwargs )
File '/usr/lib/pymodules/python2.6/univention/management/console/modules/udm/__init__.py', line 237, in _thread
dn = module.create( properties, container = options.get( 'container' ), superordinate = options.get( 'superordinate' ) )
File '/usr/lib/pymodules/python2.6/univention/management/console/modules/udm/udm_ldap.py', line 130, in wrapper_func
ret = func( *args, **kwargs )
File '/usr/lib/pymodules/python2.6/univention/management/console/modules/udm/udm_ldap.py', line 290, in create
obj.create()
File '/usr/lib/pymodules/python2.6/univention/admin/handlers/__init__.py', line 332, in create
return self._create()
File '/usr/lib/pymodules/python2.6/univention/admin/handlers/__init__.py', line 627, in _create
al.extend(self._ldap_modlist())
File '/usr/lib/pymodules/python2.6/univention/admin/handlers/users/user.py', line 2249, in _ldap_modlist
if self.hasChanged('locked'):
File '/usr/lib/pymodules/python2.6/univention/admin/handlers/users/user.py', line 1640, in hasChanged
return self.__pwd_is_locked(password) or
File '/usr/lib/pymodules/python2.6/univention/admin/handlers/users/user.py', line 1236, in __pwd_is_locked
if password.startswith('{crypt}!') or password.startswith('{LANMAN}!'):

AttributeError: 'NoneType' object has no attribute 'startswith'
Comment 1 Florian Best univentionstaff 2011-12-16 09:09:25 CET
*** Bug 7331 has been marked as a duplicate of this bug. ***
Comment 2 Florian Best univentionstaff 2011-12-16 09:10:33 CET
*** Bug 8313 has been marked as a duplicate of this bug. ***
Comment 3 Jan Christoph Ebersbach univentionstaff 2012-05-02 14:15:17 CEST
Wenn ich im UMC einen Benutzer anlege, der nur die Option Posix Konto aktiviert hat, gibt es in der GUI den Fehler "Das UDM-Objekt konnte nicht gespeichert werden: LDAP-Fehler". Erst mit dem Aktivieren der Option Persönliche Informationen ist das Anlegen möglich.
Comment 4 Jan Christoph Ebersbach univentionstaff 2012-05-02 14:35:48 CEST
(In reply to comment #3)
> Wenn ich im UMC einen Benutzer anlege, der nur die Option Posix Konto aktiviert
> hat, gibt es in der GUI den Fehler "Das UDM-Objekt konnte nicht gespeichert
> werden: LDAP-Fehler". Erst mit dem Aktivieren der Option Persönliche
> Informationen ist das Anlegen möglich.

Zu diesem Kommentar wurde ein weiterer Bug #26965 angelegt.
Comment 5 Lukas Walter univentionstaff 2013-05-14 10:12:29 CEST
Tritt mit UCS 3.1-1 immernoch auf.
Comment 6 Lukas Walter univentionstaff 2013-07-02 13:53:55 CEST
*** Bug 26965 has been marked as a duplicate of this bug. ***
Comment 7 Lukas Walter univentionstaff 2013-07-02 13:54:52 CEST
Im Zuge von Bug #31868 mitbehoben.
Comment 8 Alexander Kläser univentionstaff 2013-07-03 10:10:31 CEST
(In reply to Lukas Walter from comment #6)
> *** Bug 26965 has been marked as a duplicate of this bug. ***

Kein Duplikat mehr, ich konnte den Bug auf einem UCS 3.1-1 errata128 nicht nachvollziehen. Er scheint vorher schon gefixt.
Comment 9 Alexander Kläser univentionstaff 2013-07-05 11:31:23 CEST
I can now create a user with only the option "person" set.

Erratum changes → OK
YAML file → OK
3.2 changes → OK
3.2 changelog → OK
Comment 10 Alexander Kläser univentionstaff 2013-07-05 11:31:59 CEST
YAML file: 2013-06-25-univention-directory-manager-modules.yaml
Comment 11 Moritz Muehlenhoff univentionstaff 2013-07-10 14:18:58 CEST
http://errata.univention.de/ucs/3.1/147.html