Bug 27898 - Medienwechsel im laufenden Betrieb
Medienwechsel im laufenden Betrieb
Status: RESOLVED DUPLICATE of bug 23394
Product: UCS
Classification: Unclassified
Component: Virtualization - Xen
UCS 3.0
Other Linux
: P5 enhancement (vote)
: ---
Assigned To: UCS maintainers
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 15:43 CEST by Tobias Scherer
Modified: 2018-04-14 13:41 CEST (History)
1 user (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Flags outvoted (downgraded) after PO Review:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Scherer univentionstaff 2012-07-12 15:43:00 CEST
Angefragt an Ticket#: 2012071221005676

Es wäre schön wenn die Wechselmedien CD/DVD in XEN Instanzen zur Laufzeit ausgetauscht werden könnten.
Comment 1 Philipp Hahn univentionstaff 2012-07-12 16:17:25 CEST
Im UVMM-Code für UCS-2.4-4 wurde das nach der Implementierung wieder deaktiviert.

<branches/ucs-2.4/ucs/virtualization/univention-virtual-machine-manager-daemon/umc/modules/univention/management/console/handlers/uvmm/__init__.py>:990
# Xen can change source, but ...
# 1) this requires both libvirt.VIR_DOMAIN_DEVICE_MODIFY_LIVE | libvirt.VIR_DOMAIN_DEVICE_MODIFY_CONFIG,
# 2) xend barfs with "xend_post: error from xen daemon: (xend.err 'Device 832 not connected')" in File "/usr/lib/python2.5/site-packages/xen/xend/XendDomainInfo.py", line 1218, in device_configure

Ursache war IMHO, daß ein Wechsel nur mit HVM-Domains funktioniert hat und nicht mit PV-Domains.
Oder es war abhängig davon, ob das Laufwerk HV (d.h. qemu-emuliert) oder PV (blktap) war.

Siehe Bug #21763 und Bug #23394

*** This bug has been marked as a duplicate of bug 23394 ***