Bug 29498 - Grid reloads when having Superordinates
Grid reloads when having Superordinates
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - DNS
UNSTABLE
Other Linux
: P4 normal (vote)
: UCS 3.2
Assigned To: Dirk Wiesenthal
Alexander Kläser
: interim-1
: 29557 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-30 17:22 CET by Dirk Wiesenthal
Modified: 2013-11-19 06:41 CET (History)
4 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Usability
Max CVSS v3 score:


Attachments
reload bei form.ready() (1.69 KB, patch)
2012-11-30 17:23 CET, Dirk Wiesenthal
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Wiesenthal univentionstaff 2012-11-30 17:22:50 CET
Wenn man in der Erweiterten Suche in einer UDM-Modul-Übersicht das "Übergeordnete Objekt" ändert, verändern sich die Knöpfe unten, aber das Grid bleibt so, wie es ist.

Ich hatte mal einen Patch für ein ähnliches Problem geschrieben, das hatte sich dann aber anders lösen lassen. Vielleicht funktioniert er noch. (Man kann ihn wahrscheinlich nicht mit patch einspielen, weil ich gerade noch andere Sachen rausschneiden musste)
Comment 1 Dirk Wiesenthal univentionstaff 2012-11-30 17:23:34 CET
Created attachment 4853 [details]
reload bei form.ready()
Comment 2 Alexander Kläser univentionstaff 2012-12-03 09:48:14 CET
IMHO ist das OK so. Bei den anderen ComboBoxen verhält es sich ja auch so, man wählt aus und bei Klick auf "Suchen" werden die Ergebnisse aktualaisiert.
Comment 3 Dirk Wiesenthal univentionstaff 2012-12-03 10:45:58 CET
Das Verhalten ist momentan aber ziemlich verwirrend. Denn das Ändern des übergordneten Objekts ändert die Knöpfe unterhalb des Grids, nur nicht das Grid selbst.

Dort ist dann zum Beispiel ein Knopf "Alle DNS-Zonen zeigen", obwohl momentan alle DNS-Zonen gezeigt werden. Ob sich überhaupt etwas ändern muss, kann man diskutieren, aber entweder beide Sachen (Grid und Grid-Knöpfe) oder nichts von beidem.
Comment 4 Alexander Kläser univentionstaff 2012-12-03 11:17:45 CET
(In reply to comment #3)
> Das Verhalten ist momentan aber ziemlich verwirrend. Denn das Ändern des
> übergordneten Objekts ändert die Knöpfe unterhalb des Grids, nur nicht das Grid
> selbst.
> 
> Dort ist dann zum Beispiel ein Knopf "Alle DNS-Zonen zeigen", obwohl momentan
> alle DNS-Zonen gezeigt werden. Ob sich überhaupt etwas ändern muss, kann man
> diskutieren, aber entweder beide Sachen (Grid und Grid-Knöpfe) oder nichts von
> beidem.

OK, ja, das stimmt.
Comment 5 Alexander Kläser univentionstaff 2013-04-05 14:02:46 CEST
*** Bug 29557 has been marked as a duplicate of this bug. ***
Comment 6 Moritz Muehlenhoff univentionstaff 2013-05-31 10:45:56 CEST
We will not ship a UCS 3.1-2 release; the next UCS release will be UCS 3.2.

As such, this bug is moved to the new target milestone.
Comment 7 Dirk Wiesenthal univentionstaff 2013-07-18 18:34:14 CEST
The attached patch has already been applied. Seems to be fixed since 3.1-1...
Comment 8 Alexander Kläser univentionstaff 2013-08-05 19:03:23 CEST
(In reply to Dirk Wiesenthal from comment #7)
> The attached patch has already been applied. Seems to be fixed since 3.1-1...

Yes in commit 38123.

The UCR variable autosearch should be evaluated, as it is being done in line 443:

> var autoSearch = this._ucr['directory/manager/web/modules/' + this.moduleFlavor + '/search/autosearch'] ||
>     this._ucr['directory/manager/web/modules/autosearch'];

Changelog missing.

→ REOPENED
Comment 9 Dirk Wiesenthal univentionstaff 2013-08-06 13:41:38 CEST
Initially created to fix the buttons of the bottom of the grid while changing the superordinate, this bug has become more general:

Autosearch is not correctly evaluated: The grid filters as soon as the superordinate changes - which is at the beginning - even though autosearch=0.

This has been fixed in:
  univention-management-console-module-udm 4.0.12-1.332.201308061333

The grid still filters() in the following cases: autosearch=1, clicking the "Up"-button, clicking on a superordinate in the grid itself. It does _not_ filter when autosearch=0 and changing the superordinate in the advanced search form.

Changelog updated.
Comment 10 Alexander Kläser univentionstaff 2013-08-07 18:31:40 CEST
(In reply to Dirk Wiesenthal from comment #9)
> Initially created to fix the buttons of the bottom of the grid while
> changing the superordinate, this bug has become more general:
> 
> Autosearch is not correctly evaluated: The grid filters as soon as the
> superordinate changes - which is at the beginning - even though autosearch=0.
> 
> This has been fixed in:
>   univention-management-console-module-udm 4.0.12-1.332.201308061333
> 
> The grid still filters() in the following cases: autosearch=1, clicking the
> "Up"-button, clicking on a superordinate in the grid itself. It does _not_
> filter when autosearch=0 and changing the superordinate in the advanced
> search form.

Setting directory/manager/web/modules/autosearch=0, the query is nevertheless re-evaluated as soon as a new superordinate object has been added.
→ REOPENED

> Changelog updated.

Changelog → OK
Comment 11 Dirk Wiesenthal univentionstaff 2013-08-08 15:58:46 CEST
(In reply to Alexander Kläser from comment #10)
> (In reply to Dirk Wiesenthal from comment #9)
> Setting directory/manager/web/modules/autosearch=0, the query is
> nevertheless re-evaluated as soon as a new superordinate object has been
> added.
> → REOPENED
> 

I do not think this should be fixed. At least not here. As far as I can see this has nothing to do with superordinates. It happens also with Computers or other UDM modules *once the grid was populated*.

If you have autosearch=0 and you add a new DNS Forward Zone in a "clean" grid, it does not reload. It does, if you have searched for all objects before.

The code is not in udm.js but in umc/widgets/Grid.js, beginning with "// FIXME: should not be needed anymore with Dojo 1.8". And I think it is triggered by moduleStore._genericMultiCmd.

If this should be changed this would have to be done in another bug. But I think it is better left where it is. If someone has already searched and populated the grid and then adds a new item, he will want to see it immediately (same holds for "remove").
Comment 12 Alexander Kläser univentionstaff 2013-08-12 17:43:44 CEST
(In reply to Dirk Wiesenthal from comment #11)
> I do not think this should be fixed. At least not here. As far as I can see
> this has nothing to do with superordinates. It happens also with Computers
> or other UDM modules *once the grid was populated*.
> 
> If you have autosearch=0 and you add a new DNS Forward Zone in a "clean"
> grid, it does not reload. It does, if you have searched for all objects
> before.

Agreed → VERIFIED
Comment 13 Stefan Gohmann univentionstaff 2013-11-19 06:41:58 CET
UCS 3.2 has been released:
 http://docs.univention.de/release-notes-3.2-en.html
 http://docs.univention.de/release-notes-3.2-de.html

If this error occurs again, please use "Clone This Bug".