Bug 30543 - Don't restart bind9 in S4 init script
Don't restart bind9 in S4 init script
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Samba4
UCS 3.1
Other Linux
: P5 enhancement (vote)
: UCS 3.2
Assigned To: Arvid Requate
Stefan Gohmann
: interim-3
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-21 15:58 CET by Stefan Gohmann
Modified: 2013-11-19 06:43 CET (History)
1 user (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Cleanup
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2013-02-21 15:58:50 CET
I think the bind9 restart is longer required in the s4 init script and should be removed.
Comment 1 Arvid Requate univentionstaff 2013-10-17 17:14:53 CEST
Fixed via Bug #31698.

*** This bug has been marked as a duplicate of bug 31698 ***
Comment 2 Stefan Gohmann univentionstaff 2013-10-23 09:26:06 CEST
Changelog + code + test OK, but I set the bug to fixed.
Comment 3 Stefan Gohmann univentionstaff 2013-10-25 10:14:06 CEST
I had a problem while migration from S3 to S4. From the log output:
---------------------------------------------------------------------------------
Setting dns/backend
Restarting bind9 daemon: .
done.
Wait for bind9: .Stopping Samba AD DC daemon: samba. nmbd.
Starting Samba AD DC daemon: samba nmbd.
...........................
.........../...........^[.
...................................................................................................................................................Stopping Samba AD DC daemon: samba. nmbd.
Starting Samba AD DC daemon: samba nmbd.
...............................................................................................................................................................................
---------------------------------------------------------------------------------

It worked only after restarting bind:
root@master851:~# /etc/init.d/bind9 restart
Restarting bind9 daemon: .
done.
root@master851:~# host -al $(dnsdomainname)
Trying "deadlock85.deadlock.dead.local"
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 11914
;; flags: qr aa ra; QUERY: 1, ANSWER: 27, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;deadlock85.deadlock.dead.local.        IN      AXFR
...
Comment 4 Arvid Requate univentionstaff 2013-10-28 16:21:11 CET
Could not reproduce the bug in the test environment in two attempts.
Comment 5 Stefan Gohmann univentionstaff 2013-10-29 13:06:12 CET
(In reply to Arvid Requate from comment #4)
> Could not reproduce the bug in the test environment in two attempts.

OK, I was also unable to reproduce it again.
Comment 6 Stefan Gohmann univentionstaff 2013-11-19 06:43:04 CET
UCS 3.2 has been released:
 http://docs.univention.de/release-notes-3.2-en.html
 http://docs.univention.de/release-notes-3.2-de.html

If this error occurs again, please use "Clone This Bug".