Bug 31422 - memberOf overlay: anonymous bind on DC Slave not activated by default, replication fails
memberOf overlay: anonymous bind on DC Slave not activated by default, replic...
Status: CLOSED WORKSFORME
Product: UCS
Classification: Unclassified
Component: LDAP
UCS 3.1
Other Linux
: P5 normal (vote)
: UCS 3.2-3-errata
Assigned To: Arvid Requate
Felix Botner
:
Depends on:
Blocks: 35831
  Show dependency treegraph
 
Reported: 2013-05-22 22:07 CEST by Ingo Steuwer
Modified: 2014-09-11 07:56 CEST (History)
4 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ingo Steuwer univentionstaff 2013-05-22 22:07:55 CEST
The documentation of univention-ldap-overlay-memberof recommends to use ldap/acl/read/ips for activating anonymous bind for the local system. This is done on DC Master/Backup by the package itself, but not on DC Slaves. If not activated, DC Slaves can't replicate anymore as the first LDAP-change stalls in the overlay module.

Is there any reason for not activating it on a DC Slave by default?
Comment 1 Arvid Requate univentionstaff 2013-05-23 11:30:45 CEST
No special reason, see Bug 24433 Comment 3. The problem on UCS Slaves was simply not observed yet during fix and QA (which is strange indeed..).
Comment 2 Arvid Requate univentionstaff 2014-09-04 13:40:15 CEST
ldap/acl/read/ips is only required on the DC Master, because it is only required if there is no "rootdn" defined in slapd.conf. On DC Backup and DC Slave systems (ldap/server/type=slave) the rootdn is set, which is used by the memberof overlay to search and is used in the ACL checks.

I also cannot reproduce this join/replication issue in ucs_3.2-3.
Comment 3 Felix Botner univentionstaff 2014-09-08 10:30:32 CEST
Works for me too, 

Master:
 -> univention-install univention-ldap-overlay-memberof
 -> /usr/share/univention-ldap-overlay-memberof/univention-update-memberof
 -> univention-ldapsearch  '(uid=*)' memberOf

Slave:
 -> univention-install univention-ldap-overlay-memberof
 -> univention-ldapsearch  '(uid=*)' memberOf
Comment 4 Stefan Gohmann univentionstaff 2014-09-11 07:56:35 CEST
Nothing to release.