Bug 31803 - Show info message after app installation
Show info message after app installation
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - App-Center
UCS 3.1
Other Linux
: P5 enhancement (vote)
: UCS 3.2
Assigned To: Dirk Wiesenthal
Alexander Kläser
: interim-1
: 30176 (view as bug list)
Depends on: 32179
Blocks: 31985
  Show dependency treegraph
 
Reported: 2013-06-25 06:53 CEST by Stefan Gohmann
Modified: 2013-11-19 06:42 CET (History)
1 user (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Release Goal
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2013-06-25 06:53:48 CEST
It should be possible to show an info message (popup) after the installation of an app. Also after the upgrade.

In the style of README_UPDATE. The files should show the content as HTML.

To make it consistent we should allow / support:
 - README_UPDATE
 - REAME_POST_UPDATE
 - README_INSTALLATION
 - REAME_POST_INSTALLATION

It should be documented in wiki or in the Developer Guide:
 http://wiki.univention.de/index.php?title=App_Center_-_.ini_file
 http://docs.univention.de/developer-reference-3.1.html
Comment 1 Stefan Gohmann univentionstaff 2013-07-08 14:07:00 CEST
Please consider Bug #31886.
Comment 2 Dirk Wiesenthal univentionstaff 2013-07-11 16:46:21 CEST
*** Bug 30176 has been marked as a duplicate of this bug. ***
Comment 3 Dirk Wiesenthal univentionstaff 2013-07-16 12:58:50 CEST
Fixed in
  univention-management-console-module-appcenter 3.0.6-1.150.201307161230

The following READMEs are now supported:
 - LICENSE_AGREEMENT
 - README_INSTALLATION
 - REAME_POST_INSTALLATION
 - README_UPDATE
 - README_POST_UPDATE
 - (README - only used in "Installed Apps")

All of them allow HTML, all of them allow localization (e.g. README_POST_INSTALLATION_DE) with fallback:
  DE: README_POST_INSTALLATION_DE -> README_POST_INSTALLATION_EN -> README_POST_INSTALLATION
  EN: README_POST_INSTALLATION_EN -> README_POST_INSTALLATION

Note that as this applies to "old" READMEs like LICENSE_AGREEMENT one might need to convert those from UCS 3.1.
Comment 4 Dirk Wiesenthal univentionstaff 2013-07-16 13:40:38 CEST
(In reply to Stefan Gohmann from comment #0)
> It should be documented in wiki or in the Developer Guide:
>  http://wiki.univention.de/index.php?title=App_Center_-_.ini_file
>  http://docs.univention.de/developer-reference-3.1.html

Documented in Developer Reference
Comment 5 Alexander Kläser univentionstaff 2013-08-06 18:12:45 CEST
(In reply to Stefan Gohmann from comment #0)
> ...
> It should be documented in wiki or in the Developer Guide:
>  http://wiki.univention.de/index.php?title=App_Center_-_.ini_file
>  http://docs.univention.de/developer-reference-3.1.html

This has not yet been done → REOPENED
Comment 6 Alexander Kläser univentionstaff 2013-08-06 18:13:44 CEST
(In reply to Alexander Kläser from comment #5)
> (In reply to Stefan Gohmann from comment #0)
> > ...
> > It should be documented in wiki or in the Developer Guide:
> >  http://wiki.univention.de/index.php?title=App_Center_-_.ini_file
> >  http://docs.univention.de/developer-reference-3.1.html
> 
> This has not yet been done → REOPENED

My mistake (see comment 4).
Comment 7 Alexander Kläser univentionstaff 2013-08-06 19:19:40 CEST
(In reply to Dirk Wiesenthal from comment #4)
> Documented in Developer Reference

OK, README files are documented. The main QA for the text will be done via Bug 31226.

I would suggest a localization through the form README.de or README_UPDATE.de instead of *_DE. This would be IMHO more obvious.
Comment 8 Alexander Kläser univentionstaff 2013-08-07 15:38:25 CEST
(In reply to Dirk Wiesenthal from comment #3)
> ...
>  - README_INSTALLATION
>  - REAME_POST_INSTALLATION

In fact, these are:

 - README_INSTALL
 - REAME_POST_INSTALL
Comment 9 Alexander Kläser univentionstaff 2013-08-07 16:34:19 CEST
Changelog → OK
HTML format → OK
localization of README files → OK

Prompting README_POST_INSTALL, README_POST_UPDATE does not have a default button.
→ REOPENED

(In reply to Alexander Kläser from comment #7)
> ...
> I would suggest a localization through the form README.de or
> README_UPDATE.de instead of *_DE. This would be IMHO more obvious.

Not yet... → I opened Bug 32182
Comment 10 Dirk Wiesenthal univentionstaff 2013-08-08 12:47:36 CEST
(In reply to Alexander Kläser from comment #9)
> Changelog → OK
> HTML format → OK
> localization of README files → OK
> 
> Prompting README_POST_INSTALL, README_POST_UPDATE does not have a default
> button.
> → REOPENED

Fixed in:
  univention-management-console-module-appcenter 3.0.14-1.164.201308081215

I also changed the fallback for localisation from:
  locale || 'en' || generic
to
  locale || generic || 'en'

because I found a license agreement that had both English and German in the generic version. If this App provided a LICENSE_AGREEMENT_EN the generic version (with the German part) would not be shown if locale == "de".

Although I doubt that this will have any impact as localised files either be "complete" or completely missing.
Comment 11 Alexander Kläser univentionstaff 2013-08-12 17:17:40 CEST
(In reply to Dirk Wiesenthal from comment #10)
> Fixed in:
>   univention-management-console-module-appcenter 3.0.14-1.164.201308081215
> 
> I also changed the fallback for localisation from:
>   locale || 'en' || generic
> to
>   locale || generic || 'en'
> 
> because I found a license agreement that had both English and German in the
> generic version. If this App provided a LICENSE_AGREEMENT_EN the generic
> version (with the German part) would not be shown if locale == "de".
> 
> Although I doubt that this will have any impact as localised files either be
> "complete" or completely missing.

Looks good now → VERIFIED
Comment 12 Stefan Gohmann univentionstaff 2013-11-19 06:42:41 CET
UCS 3.2 has been released:
 http://docs.univention.de/release-notes-3.2-en.html
 http://docs.univention.de/release-notes-3.2-de.html

If this error occurs again, please use "Clone This Bug".