Bug 32592 - univention-dnsedit fails to remove last service record
univention-dnsedit fails to remove last service record
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UDM - CLI
UCS 3.2
Other Linux
: P5 normal (vote)
: UCS 3.2
Assigned To: Lukas Walter
Felix Botner
: interim-3
: 28794 (view as bug list)
Depends on:
Blocks: 32492
  Show dependency treegraph
 
Reported: 2013-09-13 15:58 CEST by Janek Walkenhorst
Modified: 2013-11-19 06:42 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Janek Walkenhorst univentionstaff 2013-09-13 15:58:19 CEST
univention-dnsedit fails to remove the last service record:

# /usr/share/univention-directory-manager-tools/univention-dnsedit "ucs32.test" add srv foo tcp 0 0 12345 "amd64.ucs32.test."
Adding SRV record "foo tcp 0 0 12345 amd64.ucs32.test." to zone ucs32.test...
done

# /usr/share/univention-directory-manager-tools/univention-dnsedit "ucs32.test" remove srv foo tcp 0 0 12345 "amd64.ucs32.test."
E: failed The property Location is required

It probably should delete the whole UDM object instead of trying to modify the location property to an empty list.
Comment 1 Stefan Gohmann univentionstaff 2013-09-13 19:53:30 CEST
See Patch at Bug #28794
Comment 2 Stefan Gohmann univentionstaff 2013-09-13 19:53:49 CEST
*** Bug 28794 has been marked as a duplicate of this bug. ***
Comment 3 Lukas Walter univentionstaff 2013-10-01 15:46:59 CEST
Patch applied with minor style changes.
Seems to be working now.

univention-directory-manager-modules (9.0.43-1)
svn r44644
Comment 4 Felix Botner univentionstaff 2013-10-22 12:17:20 CEST
OK - service record is removed from forward zone if last location is deleted
OK - Changelog
Comment 5 Stefan Gohmann univentionstaff 2013-11-19 06:42:54 CET
UCS 3.2 has been released:
 http://docs.univention.de/release-notes-3.2-en.html
 http://docs.univention.de/release-notes-3.2-de.html

If this error occurs again, please use "Clone This Bug".