Bug 35202 - univention-check-templates breaks on conffiles with space in name if python-debian is installed
univention-check-templates breaks on conffiles with space in name if python-d...
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UCR
UCS 3.2
Other Linux
: P5 normal (vote)
: UCS 3.2-3-errata
Assigned To: Felix Botner
Philipp Hahn
:
Depends on:
Blocks: 35910
  Show dependency treegraph
 
Reported: 2014-06-26 15:41 CEST by Janis Meybohm
Modified: 2014-09-11 15:05 CEST (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:
meybohm: Patch_Available+


Attachments
Use rsplit instead (859 bytes, patch)
2014-06-26 15:41 CEST, Janis Meybohm
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Janis Meybohm univentionstaff 2014-06-26 15:41:33 CEST
Created attachment 5975 [details]
Use rsplit instead

Ticket#: 2014061721000508


If a package provides conffiles with space in name AND python-debian is installed, univention-check-templates breaks:
---
Traceback (most recent call last):
  File "/usr/sbin/univention-check-templates", line 168, in <module>
    sys.exit(main())
  File "/usr/sbin/univention-check-templates", line 52, in main
    modified |= check_md5(opt.verbose)
  File "/usr/sbin/univention-check-templates", line 102, in check_md5
    for filepath, expected in iter_templates():
  File "/usr/sbin/univention-check-templates", line 134, in iter_templates
    filepath, fmd5 = fields
ValueError: too many values to unpack
---
Comment 1 Felix Botner univentionstaff 2014-09-01 16:07:15 CEST
ok, fixed

YAML: 2014-08-28-univention-config-registry.yaml

Merged to 4.0
Comment 2 Philipp Hahn univentionstaff 2014-09-02 16:30:29 CEST
OK: announce_errata -V 2014-08-28-univention-config-registry.yaml
OK: univention-check-templates (w python-debian)
OK: univention-check-templates (w/o python-debian)
OK: aptitude install '?source-package(univention-config)?installed'
OK: UCS-3.2-3 python2.6
OK: UCS_4.0-0 python2.7
Comment 3 Janek Walkenhorst univentionstaff 2014-09-10 17:34:42 CEST
http://errata.univention.de/ucs/3.2/189.html