Bug 35647 - Synced objects mustn't be counted in AD member mode
Synced objects mustn't be counted in AD member mode
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: License
UCS 3.2
Other Linux
: P5 normal (vote)
: UCS 3.2-3-errata
Assigned To: Arvid Requate
Felix Botner
:
: 38236 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-08-20 06:30 CEST by Stefan Gohmann
Modified: 2018-11-28 14:06 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Flags outvoted after Product Owner Review:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2014-08-20 06:30:37 CEST
Objects with the univentionObjectFlag set to synced mustn't be counted as part of the license in AD member mode.
Comment 1 Stefan Gohmann univentionstaff 2014-08-20 06:32:34 CEST
Please also add a test case for this. See tests/00_base/01_ignore_disabled_users_in_license_count as an example.
Comment 2 Arvid Requate univentionstaff 2014-08-25 15:48:19 CEST
Test cases:
* 01_ignore_synced_clients_in_license_count
* 01_ignore_synced_users_in_license_count

Advisory: 2014-08-25-univention-directory-manager-modules.yaml
Comment 3 Felix Botner univentionstaff 2014-08-26 14:04:46 CEST
FAIL - tests OK, but please restore ad/member  

OK - synced objects are ignored in ad member mode  
OK - merged to UCS 4.0
Comment 4 Arvid Requate univentionstaff 2014-08-26 14:28:38 CEST
> FAIL - tests OK, but please restore ad/member

The line
 with UCSTestConfigRegistry() as ucr_test:
should already do that?
Comment 5 Felix Botner univentionstaff 2014-08-26 14:34:23 CEST
(In reply to Arvid Requate from comment #4)
> > FAIL - tests OK, but please restore ad/member
> 
> The line
>  with UCSTestConfigRegistry() as ucr_test:
> should already do that?

Yep,

OK - tests
OK - synced objects are ignored in ad member mode  
OK - merged to UCS 4.0
OK - YAML 2014-08-25-univention-directory-manager-modules.yaml
Comment 6 Janek Walkenhorst univentionstaff 2014-08-27 14:34:52 CEST
http://errata.univention.de/ucs/3.2/183.html
Comment 7 Felix Botner univentionstaff 2018-11-28 14:06:37 CET
*** Bug 38236 has been marked as a duplicate of this bug. ***