Bug 35860 - Replication check
Replication check
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - System diagnostic
UCS 4.0
Other Linux
: P5 enhancement (vote)
: UCS 4.2-2-errata
Assigned To: Lukas Oyen
Arvid Requate
:
: 35857 37236 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-09-10 08:28 CEST by Stefan Gohmann
Modified: 2017-09-20 15:03 CEST (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:
oyen: Patch_Available+


Attachments
35860-diagnostic-join-status-420.patch (10.04 KB, patch)
2017-05-31 18:31 CEST, Lukas Oyen
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2014-09-10 08:28:43 CEST
We should add a system diagnostic plugin which checks the join status. If an error has been found, it should link to the UCS manual:
 http://docs.univention.de/manual.html#domain:listenernotifier:erroranalysis
 http://docs.univention.de/handbuch.html#domain:listenernotifier:erroranalysis
Comment 1 Lukas Oyen univentionstaff 2017-05-31 18:31:35 CEST
Created attachment 8892 [details]
35860-diagnostic-join-status-420.patch

The attached patches, based on Julian Hupertz original check, implement a `check_join_status.py` for the diagnostic module.

In case of an error, the manual and the UDM module `join` is linked.
Comment 2 Lukas Oyen univentionstaff 2017-05-31 18:32:15 CEST
*** Bug 37236 has been marked as a duplicate of this bug. ***
Comment 3 Lukas Oyen univentionstaff 2017-05-31 18:32:27 CEST
*** Bug 35857 has been marked as a duplicate of this bug. ***
Comment 4 Lukas Oyen univentionstaff 2017-08-01 16:24:19 CEST
Committed in r81602 - r81604 (advisory r81649).
Comment 5 Arvid Requate univentionstaff 2017-08-24 21:50:40 CEST
Ok, works.
Comment 6 Erik Damrose univentionstaff 2017-09-20 15:03:36 CEST
<http://errata.software-univention.de/ucs/4.2/166.html>