Bug 35952 - univention-register-apps holds a DC backup installation
univention-register-apps holds a DC backup installation
Status: CLOSED DUPLICATE of bug 36044
Product: UCS
Classification: Unclassified
Component: App Center
UCS 3.2
Other Linux
: P5 normal (vote)
: UCS 4.0-2-errata
Assigned To: Dirk Wiesenthal
Florian Best
Depends on:
  Show dependency treegraph
Reported: 2014-09-18 07:36 CEST by Stefan Gohmann
Modified: 2015-07-29 12:57 CEST (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Flags outvoted (downgraded) after PO Review:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2014-09-18 07:36:02 CEST
A DC backup test installation got stuck in join script  35univention-management-console-module-appcenter.inst. It continues after 15 minutes.

# ps -ef | grep 29547
root     29547 27452  0 07:14 tty1     00:00:00 /bin/sh /usr/lib/univention-install/35univention-management-console-module-appcenter.inst --binddn uid=Administrator,cn=users,dc=deadlock19,dc=local --bindpwd univention
root     29649 29547  0 07:14 tty1     00:00:00 /usr/bin/python2.6 /usr/sbin/univention-register-apps

# strace -f -p 29649
Process 29649 attached - interrupt to quit

# ls -la /proc/29649/fd/5
lrwx------ 1 root root 64 18. Sep 07:20 /proc/29649/fd/5 -> socket:[62265]

While writing this bug, the process continued. So I was unable to copy the netstat output. I could see that the socket was a http connection to our download server.

A similar issue has been fixed with Bug #34834 and changed with Bug #32935.
Comment 1 Stefan Gohmann univentionstaff 2015-06-25 06:56:39 CEST
It looks like the problem didn't happen again, right?

Dirk, did you already try to reproduce it? If you weren't able to reproduce it, please close the bug as WORKSFORME. If you didn't have the time, please reset the target milestone to 4.0-x and give the bug back to the default assignee.
Comment 2 Dirk Wiesenthal univentionstaff 2015-06-25 10:16:02 CEST
I tried to reproduce it but with no success. Jenkins runs 35univention-management-console-module-appcenter.inst every time, too. WORKSFORME until further occurrence.
Comment 3 Florian Best univentionstaff 2015-07-09 17:40:06 CEST
OK, I had a look at the source code. The UniventionUpdater() class can only be the reason for this afaics. Bug #36044 fixed it.

*** This bug has been marked as a duplicate of bug 36044 ***