Bug 40657 - join during installation fails, if eth0 is not defined
join during installation fails, if eth0 is not defined
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Join (univention-join)
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-2-errata
Assigned To: Jürn Brodersen
Erik Damrose
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 13:13 CET by Christina Scheinig
Modified: 2017-09-20 15:03 CEST (History)
4 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 6: Setup Problem: Issue for the setup process
Who will be affected by this bug?: 1: Will affect a very few installed domains
How will those affected feel about the bug?: 3: A User would likely not purchase the product
User Pain: 0.103
Enterprise Customer affected?: Yes
School Customer affected?: Yes
ISV affected?:
Waiting Support:
Ticket number: 2016020821000403, 2017062121000227
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christina Scheinig univentionstaff 2016-02-15 13:13:36 CET
During installation, joining a slave fails, if eth0 is not defined. Even skipping this step doesn't work.

If the hardware has more than one network interface and only eth1 is configured the installer returns an error that network configuration is not valid.
Using a dummy configuration for eth0 seems to be a workaround.

See Ticket#2016020821000403
Comment 1 Jens Thorp-Hansen univentionstaff 2017-06-21 14:41:18 CEST
happend again Ticket#2017062121000227
Comment 2 Jürn Brodersen univentionstaff 2017-09-18 11:38:54 CEST
The first configured interface should now be set as the primary interface instead of the first existing interface.

merge commit:
2d8ba40286348f0850af2a20cde8b03410424442

Package: univention-system-setup
Version: 10.0.10-42A~4.2.0.201709151629
Branch: ucs_4.2-0
Scope: errata4.2-2
Comment 3 Erik Damrose univentionstaff 2017-09-20 11:00:58 CEST
OK: reproduce original error
OK: fix: set interfaces/primary to configured interface
OK: setup with only eth1 configured, eth0 unconfigured
OK: setup with eth1 and eth0 configured
OK: setup with eth0 configured, eth1 unconfigured
OK: yaml
Verified
Comment 4 Erik Damrose univentionstaff 2017-09-20 15:03:51 CEST
<http://errata.software-univention.de/ucs/4.2/177.html>