Bug 45180 - zsync does not work if destination is on a different partition (Invalid cross-device link)
zsync does not work if destination is on a different partition (Invalid cross...
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: App Center
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-1-errata
Assigned To: Felix Botner
Eduard Mai
:
Depends on:
Blocks: 45182
  Show dependency treegraph
 
Reported: 2017-08-10 15:03 CEST by Felix Botner
Modified: 2017-09-15 10:38 CEST (History)
4 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 5: Major Usability: Impairs usability in key scenarios
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 5: Blocking further progress on the daily work
User Pain: 0.286
Enterprise Customer affected?: Yes
School Customer affected?:
ISV affected?:
Ticket number: 2017091521000206
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Botner univentionstaff 2017-08-10 15:03:21 CEST

    
Comment 1 Felix Botner univentionstaff 2017-08-10 15:26:26 CEST
6.0.9-0A~4.2.0.201708101518 univention-appcenter errata4.2-1

chdir to all.tar directory
zsync
chdir back
Comment 2 Eduard Mai univentionstaff 2017-08-10 15:35:56 CEST
OK - issue was reproduced successfully. Installation of 6.0.9-0A~4.2.0.201708101518 fixes the broken cache.
OK - 'univention-app update' successfully rebuilds cache if emptied completely.

VERIFIED.
Comment 3 Dirk Wiesenthal univentionstaff 2017-08-10 20:40:01 CEST
Is this important?

+if dpkg --compare-versions "$2" lt-nl 56.0.8-20; then
+	univention-app update || true
+fi

Because there is a typo in the version and 56.* should always be greater than the current one (6.*), right? I guess you went to 6.0.9 because of that?
Comment 4 Felix Botner univentionstaff 2017-08-11 12:42:03 CEST
(In reply to Dirk Wiesenthal from comment #3)
> Is this important?
> 
> +if dpkg --compare-versions "$2" lt-nl 56.0.8-20; then
> +	univention-app update || true
> +fi
> 
> Because there is a typo in the version and 56.* should always be greater
> than the current one (6.*), right? I guess you went to 6.0.9 because of that?

this is not critical, we fix this in the next regular univention-appcenter update
Comment 5 Erik Damrose univentionstaff 2017-08-11 13:06:13 CEST
<http://errata.software-univention.de/ucs/4.2/132.html>