Bug 46247 - c-ares: Multiple issues (4.2)
c-ares: Multiple issues (4.2)
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Security updates
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-3-errata
Assigned To: Philipp Hahn
Arvid Requate
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-07 16:35 CET by Philipp Hahn
Modified: 2018-05-08 14:57 CEST (History)
1 user (show)

See Also:
What kind of report is it?: Security Issue
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Security
Max CVSS v3 score: 6.5 (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L)
hahn: Patch_Available+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2018-02-07 16:35:12 CET
Upstream Debian package version 1.10.0-2+deb8u2 fixes:

* c-ares NAPTR parser out of bounds access (CVE-2017-1000381)
Comment 1 Philipp Hahn univentionstaff 2018-02-07 16:36:09 CET
f4f3057518 Bug #46247: c-ares_1.10.0-2+deb8u2
Comment 2 Quality Assurance univentionstaff 2018-05-04 16:57:00 CEST
--- mirror/ftp/4.2/unmaintained/4.2-0/source/c-ares_1.10.0-2+deb8u1.dsc
+++ apt/ucs_4.2-0-errata4.2-3/source/c-ares_1.10.0-2+deb8u2.dsc
@@ -1,3 +1,7 @@
+1.10.0-2+deb8u2 [Mon, 26 Jun 2017 22:03:42 +0200] Gregor Jasny <gjasny@googlemail.com>:
+
+  * Add patch for CVE-2017-1000381 (Closes: #865360)
+
 1.10.0-2+deb8u1 [Thu, 29 Sep 2016 20:30:48 +0200] Gregor Jasny <gjasny@googlemail.com>:
 
   * Apply patch for CVE-2016-5180 (Closes: #839151)
Comment 3 Arvid Requate univentionstaff 2018-05-07 22:10:36 CEST
* No UCS specific patches
* Comparison to previously shipped version ok
* Installation Ok
* Advisory Ok
Comment 4 Arvid Requate univentionstaff 2018-05-08 14:57:02 CEST
<http://errata.software-univention.de/ucs/4.2/370.html>