Bug 9927 - UMC/Domänenbeitritt: Dialog sollte auf Neustart hinweisen
UMC/Domänenbeitritt: Dialog sollte auf Neustart hinweisen
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - Domain join
UNSTABLE
All Linux
: P4 normal (vote)
: UCS 3.2
Assigned To: Florian Best
Alexander Kläser
: interim-1
: 19563 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-26 16:15 CET by Moritz Muehlenhoff
Modified: 2013-11-19 06:42 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Moritz Muehlenhoff univentionstaff 2007-11-26 16:15:53 CET
Nach einem initialen Join eines Systems über UMC ist das System noch nicht voll funktionsfähig (sondern erst nach einem Neustart). Das sollte im UMC-Dialog erwähnt werden, da es für den User nicht transparent ist. Am besten wäre es, wenn auch direkt ein Dialog angeboten werden würde, der anbietet den Rechner neu zu starten.
Comment 1 Stefan Gohmann univentionstaff 2012-06-14 22:25:35 CEST
Der Neustart ist IMHO nicht mehr ganz so wichtig, aber immer noch empfohlen.
Comment 2 Florian Best univentionstaff 2013-07-25 10:40:29 CEST
*** Bug 19563 has been marked as a duplicate of this bug. ***
Comment 3 Florian Best univentionstaff 2013-07-25 10:42:27 CEST
lib.server.askReboot() dialog have been added in the UMC lib module.
This is used after a successful join process.

univention-join (6.0.3-1)
univention-management-console-module-lib (3.0.1-1)
Comment 4 Alexander Kläser univentionstaff 2013-08-05 18:05:48 CEST
"A reboot of the server is recommended after joining the system." → German translation is missing

"The server is now offline" → I would remove that message such that "Please wait while the server is rebooting" remains visible in the progress bar during reboot. Otherwise this could be somewhat confusing to the user, IMHO.

"Die wird einige Minuten dauern." → "Die*s* wird …"

"This will take approximately several minutes." → "This may take a few minutes."
(ditto for German)

"Please wait while the server is rebooting." → "The server is beeing rebooted

You renamed the ping method but did not adapt the method name in the ACL file and in other method (JS code):
====================
lib = require('umc/modules/lib/server')
lib.ping()
POST http://10.200.26.7/umcp/command/lib/server/ping 500 (Internal Server Error) 
====================

Changelog missing.

→ REOPENED
Comment 5 Moritz Muehlenhoff univentionstaff 2013-08-06 07:14:09 CEST
(In reply to Alexander Kläser from comment #4)
> "Please wait while the server is rebooting." → "The server is beeing rebooted
                                                                ^^^^^^
being
Comment 6 Florian Best univentionstaff 2013-08-15 17:05:07 CEST
Texts have been adapted. Methodrename has been reverted.
Comment 7 Alexander Kläser univentionstaff 2013-08-16 17:52:19 CEST
(In reply to Alexander Kläser from comment #4)
> "A reboot of the server is recommended after joining the system." → German
> translation is missing
> 
> "The server is now offline" → I would remove that message such that "Please
> wait while the server is rebooting" remains visible in the progress bar
> during reboot. Otherwise this could be somewhat confusing to the user, IMHO.
> 
> "Die wird einige Minuten dauern." → "Die*s* wird …"
> 
> "This will take approximately several minutes." → "This may take a few
> minutes."
> (ditto for German)
> 
> "Please wait while the server is rebooting." → "The server is beeing rebooted

Looks good now → OK

> You renamed the ping method but did not adapt the method name in the ACL
> file and in other method (JS code):
> ====================
> lib = require('umc/modules/lib/server')
> lib.ping()
> POST http://10.200.26.7/umcp/command/lib/server/ping 500 (Internal Server
> Error) 
> ====================

ping is back working :) → OK

> Changelog missing.

Was still missing, I added it → OK

→ VERIFIED
Comment 8 Stefan Gohmann univentionstaff 2013-11-19 06:42:09 CET
UCS 3.2 has been released:
 http://docs.univention.de/release-notes-3.2-en.html
 http://docs.univention.de/release-notes-3.2-de.html

If this error occurs again, please use "Clone This Bug".