Bug 13784 - Mehrere LDAP-Server für den Memberserver
Mehrere LDAP-Server für den Memberserver
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Samba
UCS 3.2
All All
: P5 normal (vote)
: UCS 3.2-5-errata
Assigned To: Stefan Gohmann
Felix Botner
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-19 08:36 CET by Stefan Gohmann
Modified: 2015-03-25 14:04 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2009-03-19 08:36:57 CET
Der UCS-Samba Memberserver verwendet als idmap-Backend LDAP. Neben dem ldap/server/name wird auch ldap/server/addition ausgewertet und eingetragen:

root@qamember_amd64:~# ucr search ldap/server/name
ldap/server/name: qamaster_amd64.univention.qa
root@qamember_amd64:~# ucr search ldap/server/addition
ldap/server/addition: qaslave_amd64.univention.qa
root@qamember_amd64:~# grep idmap\ backend /etc/samba/smb.conf | grep -v \#
        idmap backend = ldap:" ldap://qamaster_amd64.univention.qa  ldap://qaslave_amd64.univention.qa  "

Wenn der DC Master abgeschaltet ist, bekomme ich die Meldung:

[2009/03/17 01:14:03,  0] lib/smbldap.c:smbldap_connect_system(992)
  failed to bind to server  ldap://qamaster_amd64.univention.qa   with dn="cn=qamember_amd64,cn=memberserver,cn=computers,dc=univention,dc=qa" Error: Can't contact LDAP server
Comment 1 Sönke Schwardt-Krummrich univentionstaff 2009-08-03 12:17:39 CEST
Stefan weisst du noch, welche UCS-/Samba-Version das war?

http://forum.soft32.com/linux/IDMAP-Backend-multiple-ftopict374149.html
Comment 2 Stefan Gohmann univentionstaff 2009-08-03 16:15:07 CEST
Nein, genau nicht. Ich denke UCS 2.1.
Comment 3 Sönke Schwardt-Krummrich univentionstaff 2009-08-18 14:26:31 CEST
Bitte prüfen, ob die Angabe mehrerer LDAP-Server mit Samba 3.2.13 mittlerweile möglich ist.
Comment 4 Daniel Hofmann univentionstaff 2009-08-19 10:46:04 CEST
Mit Samba 3.2.13 auf einem Memberrechner mit UCS 2.2.2 (sowie selbiger Version auf Master und Slave) funktioniert das folgendermaßen:

nur per ucr hab ich auf dem member folgendes in die smb.conf geschrieben:

idmap backend = "ldap: ldap://qamaster.univention.test  ldap://qaslave.univention.test  "

tcpdump '(tcp port 139 or tcp port 445) and src 10.200.4.5'
auf Master und Slave hilft, eingehende Anfragen zu erkennen.
(10.200.4.5 ist die ip vom member)

Anfänglich gehen Anfragen vom member (am besten mit 'wbinfo -n $RANDOMNAME' um lokalen cache zu umgehen) brav an den Master.

Nach "ifdown eth0" auf master hängen dann die nächsten Anfragen, aber relativ bald gehen dann die weiteren Anfragen an den Slave. Das ist auch weiterhin der Fall, wenn der Master wieder erreichbar ist. Nach Neustart von winbind auf member oder ausfall des slave gehen die Anfragen wieder an Master.
Comment 5 Arvid Requate univentionstaff 2012-01-16 09:32:38 CET
Ab UCS 2.3 funktioniert das nicht mehr, siehe Bug 16665 Comment 6. Im Template ist der entsprechende Block auskommentiert mit dem Hinweis:

## the idmap backend config has undergone at least two rewites, in its current
## state (3.3.9) it does not allow more than one ldap URL.
Comment 6 Stefan Gohmann univentionstaff 2015-01-30 09:01:00 CET
See also Bug #36805.
Comment 7 Stefan Gohmann univentionstaff 2015-03-19 07:48:14 CET
ldap/server/addition has been re-added to the list of LDAP servers. Unlike my 4.0-1 setup, I was unable to reproduce the original Bug #36805. Anyway, I think it is correct to use all configured LDAP servers.

YAML: 2015-03-19-univention-samba.yaml

Fix: r59201
Comment 8 Felix Botner univentionstaff 2015-03-23 16:44:16 CET
-> more /etc/samba/smb.conf| grep ldap_ur

idmap config * : ldap_url       = ldap://master.fb.intranet:7389

-> ucr set ldap/server/addition=slave.fb.intranet
-> more /etc/samba/smb.conf| grep ldap_url

idmap config * : ldap_url       = ldap://master.fb.intranet:7389 ldap://slave.fb.intranet:7389

-> ucr set ldap/server/addition="slave.fb.intranet backup.fb.intranet"
-> more /etc/samba/smb.conf| grep ldap_url
        idmap config * : ldap_url       = ldap://master.fb.intranet:7389 ldap://slave.fb.intranet:7389 ldap://backup.fb.intranet:7389

-> ucr unset  ldap/server/addition
-> more /etc/samba/smb.conf| grep ldap_url
        idmap config * : ldap_url       = ldap://master.fb.intranet:7389

OK - 2015-03-19-univention-samba.yaml
Comment 9 Janek Walkenhorst univentionstaff 2015-03-25 14:04:14 CET
<http://errata.univention.de/ucs/3.2/308.html>