Bug 19928 - Add "Add all" checkbox to selection widgets
Add "Add all" checkbox to selection widgets
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 4.2
Other Linux
: P5 enhancement (vote)
: UCS 4.2-1-errata
Assigned To: Johannes Keiser
Florian Best
:
: 28704 38185 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-10 11:04 CEST by Andreas Büsching
Modified: 2017-07-26 14:38 CEST (History)
5 users (show)

See Also:
What kind of report is it?: Feature Request
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Ticket number:
Bug group (optional): Usability
Max CVSS v3 score:
keiser: Patch_Available+


Attachments
patch (4.80 KB, patch)
2017-07-17 15:04 CEST, Johannes Keiser
Details | Diff
adapted patch (7.60 KB, patch)
2017-07-17 15:47 CEST, Johannes Keiser
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Büsching univentionstaff 2010-09-10 11:04:56 CEST
In dem Widget werden Objekte gesucht und dann einer Gruppen hinzugefügt. Um alle gefundenen Einträge hinzuzufügen könnte es noch einen extra Button geben. Momentan müssen erst alle Objekte ausgewählt werden dann der Hinzufügen-Button geklickt werden.
Comment 1 Florian Best univentionstaff 2012-09-06 11:09:41 CEST
fände ich auch hilfreich
Comment 2 Alexander Kläser univentionstaff 2012-10-08 13:07:11 CEST
Siehe auch Bug 28704.
Comment 3 Florian Best univentionstaff 2016-10-07 18:25:30 CEST
Still not possible, still a wanted feature.
Comment 4 Johannes Keiser univentionstaff 2017-07-17 15:04:26 CEST
Created attachment 9035 [details]
patch
Comment 5 Florian Best univentionstaff 2017-07-17 15:10:30 CEST
Thanks for creating a patch. Please adjust it so that it is configurable if the all-selection is shown (defaulting to false). In MultiObjectSelect it should be shown. A property to set a different label would also be nice.
Comment 6 Johannes Keiser univentionstaff 2017-07-17 15:47:19 CEST
Created attachment 9036 [details]
adapted patch
Comment 7 Florian Best univentionstaff 2017-07-17 16:51:06 CEST
*** Bug 28704 has been marked as a duplicate of this bug. ***
Comment 8 Florian Best univentionstaff 2017-07-17 16:51:14 CEST
*** Bug 38185 has been marked as a duplicate of this bug. ***
Comment 9 Johannes Keiser univentionstaff 2017-07-19 15:50:19 CEST
(In reply to Johannes Keiser from comment #6)
> Created attachment 9036 [details]
> adapted patch

Applied patch:

r 81263
univention-web (1.0.42-21) 
* Bug #19928: add 'Select all' checkbox to MultiSelect widgets

YAML: r 81264
Comment 10 Florian Best univentionstaff 2017-07-19 18:12:13 CEST
Very good!
YAML: OK (adjusted in r81265)
Comment 11 Erik Damrose univentionstaff 2017-07-26 14:38:59 CEST
<http://errata.software-univention.de/ucs/4.2/108.html>