Bug 23055 - Prüfung auf Existenz der LDAP-Schemata beim Start
Prüfung auf Existenz der LDAP-Schemata beim Start
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: LDAP
UCS 2.4
Other Linux
: P5 enhancement (vote)
: UCS 3.2
Assigned To: Erik Damrose
Felix Botner
: interim-1
: 23418 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-19 11:33 CEST by Tim Petersen
Modified: 2013-11-19 06:43 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Flags outvoted (downgraded) after PO Review:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Petersen univentionstaff 2011-07-19 11:33:29 CEST
Es könnte beim Start des LDAP-Servers auf Existenz der Schemata geprüft werden.

Angeregt über das Forum:
http://forum.univention.de/viewtopic.php?f=48&t=1512
Comment 1 Stefan Gohmann univentionstaff 2013-04-03 21:49:29 CEST
slapschema zeigt die Fehler an und könnte im init Skript aufgerufen werden:

Nach dem Auskommentieren von /usr/share/univention-ldap/schema/msgpo.schema:

root@master501:~# slapschema 
50f7e980 OVER: Loading Translog Overlay
50f7e980 OVER: db_init
50f7e980 OVER: Configuring Translog Overlay
50f7e980 OVER: Configured Translog Overlay to use file "/var/lib/univention-ldap/listener/listener"
50f7e980 UNKNOWN attributeDescription "MSGPOLINK" inserted.
# (65) Object class violation: unrecognized objectClass 'msGPO'
dn: dc=deadlock50,dc=local

# (65) Object class violation: unrecognized objectClass 'msGPO'
dn: ou=Domain Controllers,dc=deadlock50,dc=local

50f7e980 UNKNOWN attributeDescription "MSGPOFILESYSPATH" inserted.
50f7e980 UNKNOWN attributeDescription "MSGPOMACHINEEXTENSIONNAMES" inserted.
50f7e980 UNKNOWN attributeDescription "MSGPOSYSTEMFLAGS" inserted.
50f7e980 UNKNOWN attributeDescription "MSGPOVERSIONNUMBER" inserted.
50f7e980 UNKNOWN attributeDescription "MSGPOFLAGS" inserted.
50f7e980 UNKNOWN attributeDescription "MSGPOFUNCTIONALITYVERSION" inserted.
# (65) Object class violation: unrecognized objectClass 'msGPOContainer'
dn: cn={6AC1786C-016F-11D2-945F-00C04FB984F9},cn=Policies,cn=System,dc=deadlock50,dc=local

50f7e980 UNKNOWN attributeDescription "MSGPOUSEREXTENSIONNAMES" inserted.
# (65) Object class violation: unrecognized objectClass 'msGPOContainer'
dn: cn={31B2F340-016D-11D2-945F-00C04FB984F9},cn=Policies,cn=System,dc=deadlock50,dc=local

50f7e980 OVER: db_close
50f7e980 OVER: db_destroy
root@master501:~#
Comment 2 Stefan Gohmann univentionstaff 2013-04-03 22:24:04 CEST
*** Bug 23418 has been marked as a duplicate of this bug. ***
Comment 3 Erik Damrose univentionstaff 2013-07-01 11:57:45 CEST
The slapd initscript now checks if an error occured while starting slapd. If an error occured slapschema is used to determine the error and present more information to the user.

Build in 3.2: univention-ldap 10.0.2-1.591.201307011145
Comment 4 Felix Botner univentionstaff 2013-07-04 17:39:21 CEST
OK 

  missing schema:

-> /etc/init.d/slapd start
Check database: ...done.
Starting ldap server(s): slapd ...failed.
51d59641 /usr/share/univention-ldap/schema/samba.schema: line 502 objectclass: AttributeType not found: "displayName" slapschema: bad configuration file!.

  broken acl:

-> /etc/init.d/slapd start
Check database: ...done.
Starting ldap server(s): slapd ...failed.
51d596ec OVER: Loading Translog Overlay 51d596ec OVER: db_init 51d596ec OVER: Configuring Translog Overlay 51d596ec OVER: Configured Translog Overlay to use file "/var/lib/univention-ldap/listener/listener" 51d596ec /etc/ldap/slapd.conf: line 254: expecting <access> got "uusers". 51d596ec <access clause> ::= access to <what> [ by <who> [ <access> ] [ <control> ] ]+ <what> ::= * | dn[.<dnstyle>=<DN>] [filter=<filter>] [attrs=<attrspec>] <attrspec> ::= <attrname> [val[/<matchingRule>][.<attrstyle>]=<value>] | <attrlist> <attrlist> ::= <attr> [ , <attrlist> ] <attr> ::= <attrname> | @<objectClass> | !<objectClass> | entry | children <who> ::= [ * | anonymous | users | self | dn[.<dnstyle>]=<DN> ] [ realanonymous | realusers | realself | realdn[.<dnstyle>]=<DN> ] [dnattr=<attrname>] [realdnattr=<attrname>] [group[/<objectclass>[/<attrname>]][.<style>]=<group>] [peername[.<peernamestyle>]=<peer>] [sockname[.<style>]=<name>] [domain[.<domainstyle>]=<domain>] [sockurl[.<style>]=<url>] [dynacl/<name>[/<options>][.<dynstyle>][=<pattern>]] [ssf=<n>] [transport_ssf=<n>] [tls_ssf=<n>] [sasl_ssf=<n>] <style> ::= exact | regex | base(Object) <dnstyle> ::= base(Object) | one(level) | sub(tree) | children | exact | regex <attrstyle> ::= exact | regex | base(Object) | one(level) | sub(tree) | children <peernamestyle> ::= exact | regex | ip | ipv6 | path <domainstyle> ::= exact | regex | base(Object) | sub(tree) <access> ::= [[real]self]{<level>|<priv>} <level> ::= none|disclose|auth|compare|search|read|{write|add|delete}|manage <priv> ::= {=|+|-}{0|d|x|c|s|r|{w|a|z}|m}+ <control> ::= [ stop | continue | break ] dynacl: <name>=ACI <pattern>=<attrname> slapschema: bad configuration file!.

OK - changelog
Comment 5 Stefan Gohmann univentionstaff 2013-11-19 06:43:22 CET
UCS 3.2 has been released:
 http://docs.univention.de/release-notes-3.2-en.html
 http://docs.univention.de/release-notes-3.2-de.html

If this error occurs again, please use "Clone This Bug".