Bug 24094 - univention-certificate sollte auf Backup auf Master verweisen
univention-certificate sollte auf Backup auf Master verweisen
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: SSL
UCS 3.0
Other Linux
: P5 normal (vote)
: UCS 4.1-2-errata
Assigned To: Philipp Hahn
Janek Walkenhorst
:
: 6068 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-18 14:17 CEST by Moritz Muehlenhoff
Modified: 2016-07-21 15:15 CEST (History)
1 user (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Moritz Muehlenhoff univentionstaff 2011-10-18 14:17:31 CEST
Die Doku enthält aktuell folgenden Hinweis:

\ucsExclamation\ucsAttention{Die CA wird nur vom \ucsMaster{} zum \ucsBackup{} synchronisiert und nicht umgekehrt. Es sollte also ausschließlich die CA auf dem \ucsMaster{} verwendet werden.}

univention-certificate sollte server/role auslesen und eine entsprechende Warnung ausgeben.
Comment 1 Philipp Hahn univentionstaff 2016-06-22 17:24:25 CEST
*** Bug 6068 has been marked as a duplicate of this bug. ***
Comment 2 Philipp Hahn univentionstaff 2016-06-23 14:12:37 CEST
r70558 | Bug #24094 ssl: Allow univention-certificate only on DC Master (or Backup)

Package: univention-ssl
Version: 10.0.0-11.168.201606230839
Version: 10.0.0-12.169.201606231402
Branch: ucs_4.1-0
Scope: errata4.1-2

r70577 | Bug #31369,Bug #39257,Bug #24094,Bug #40498,Bug #25285,Bug #35748: ssl YAML
 univention-ssl.yaml
Comment 3 Philipp Hahn univentionstaff 2016-06-27 17:47:43 CEST
r70643 | Bug #24094 SSL: Fix unit test
r70652 | Bug #24094 SSL: Disable unit test
 Broke UDL restart, but disabled for now

Package: univention-ssl
Version: 10.0.0-15.172.201606271746
Branch: ucs_4.1-0
Scope: errata4.1-2
Comment 4 Philipp Hahn univentionstaff 2016-06-29 10:06:19 CEST
<http://jenkins.knut.univention.de:8080/job/UCS-4.1/job/UCS-4.1-2/job/AutotestJoin/65/SambaVersion=s4,Systemrolle=backup/testReport/01_base/81alternativessl/test/>

r70693 | Bug #24094 test: Restrict 01/81ssl to DC master

Package: ucs-test
Version: 6.0.33-81.1493.201606291004
Branch: ucs_4.1-0
Scope: errata4.1-2
Comment 5 Janek Walkenhorst univentionstaff 2016-07-19 19:26:28 CEST
Code review: OK
Tests: OK
Advisory: OK
Comment 6 Janek Walkenhorst univentionstaff 2016-07-21 15:15:54 CEST
<http://errata.software-univention.de/ucs/4.1/213.html>