Bug 25113 - AD Connector: verschieben von Containern auf AD Seite
AD Connector: verschieben von Containern auf AD Seite
Status: RESOLVED DUPLICATE of bug 33482
Product: UCS
Classification: Unclassified
Component: AD Connector
UCS 3.0
Other Linux
: P5 normal (vote)
: ---
Assigned To: Connector maintainers
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-02 16:58 CET by Felix Botner
Modified: 2013-11-26 08:32 CET (History)
1 user (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Botner univentionstaff 2011-12-02 16:58:12 CET
UCS 3.0 <=> w2k8r2

read mode

Im AD folgende Container angelegt.

TESTLIBPATH="/usr/share/ucs-test/lib"
source "$TESTLIBPATH/base.lib"
source "$TESTLIBPATH/udm.lib"
source "$TESTLIBPATH/adconnector.lib"

ad_createcontainer "CONTAINER1"
ad_createcontainer "CONTAINER2"
ad_createcontainer "CONTAINER3" "" "CN=CONTAINER1,DC=w2k8r2,DC=win" 

Das hat auch für UCS geklappt.

Dann im AD den CONTAINER1 nach CONTAINER2 verschoben.

Im log steht dann folgendes:

 30.11.2011 23:25:21,625 MAIN        (------ ): DEBUG_INIT
30.11.2011 23:25:21,643 LDAP        (INFO   ): init finished
30.11.2011 23:25:21,676 LDAP        (PROCESS): sync to ucs: Resync rejected dn: CN=CONTAINER1,CN=CONTAINER2,DC=w2k8r2,DC=win
30.11.2011 23:25:21,677 LDAP        (INFO   ): Search AD with filter: (|(uSNChanged=30858)(uSNCreated=30858))
30.11.2011 23:25:21,678 LDAP        (INFO   ): encode_ad_object: attrib objectGUID ignored during encoding
30.11.2011 23:25:21,680 LDAP        (INFO   ): object_from_element: olddn: CN=CONTAINER1,DC=w2k8r2,DC=win
30.11.2011 23:25:21,680 LDAP        (INFO   ): object_from_element: detected move of AD-Object
30.11.2011 23:25:21,681 LDAP        (INFO   ): _object_mapping: map with key container and type con
30.11.2011 23:25:21,681 LDAP        (INFO   ): _dn_type con
30.11.2011 23:25:21,682 LDAP        (INFO   ): _dn_type con
30.11.2011 23:25:21,682 LDAP        (INFO   ): _ignore_object: Do not ignore CN=CONTAINER1,cn=container2,dc=w2k8,dc=r2
30.11.2011 23:25:21,683 LDAP        (INFO   ): _ignore_object: Do not ignore CN=CONTAINER1,CN=CONTAINER2,DC=w2k8r2,DC=win
30.11.2011 23:25:21,685 LDAP        (INFO   ): get_ucs_object: object found: cn=container1,dc=w2k8,dc=r2
30.11.2011 23:25:21,685 LDAP        (PROCESS): sync to ucs:   [     container] [      move] CN=CONTAINER1,cn=container2,dc=w2k8,dc=r2
30.11.2011 23:25:21,686 LDAP        (INFO   ): sync_to_ucs: set position to cn=container2,dc=w2k8,dc=r2
30.11.2011 23:25:21,686 LDAP        (INFO   ): move_in_ucs: move object from cn=container1,dc=w2k8,dc=r2 to CN=CONTAINER1,cn=container2,dc=w2k8,dc=r2
30.11.2011 23:25:21,730 LDAP        (ERROR  ): Unknown Exception during sync_to_ucs
30.11.2011 23:25:21,733 LDAP        (ERROR  ): Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/univention/connector/__init__.py", line 1072, in sync_to_ucs
    result = self.move_in_ucs(property_type, object, module, position)
  File "/usr/lib/pymodules/python2.6/univention/connector/__init__.py", line 964, in move_in_ucs
    ucs_object.move(object['dn'])
  File "/usr/lib/pymodules/python2.6/univention/admin/handlers/__init__.py", line 396, in move
    subobject.move(subnewdn)
  File "/usr/lib/pymodules/python2.6/univention/admin/handlers/__init__.py", line 396, in move
    subobject.move(subnewdn)
  File "/usr/lib/pymodules/python2.6/univention/admin/handlers/__init__.py", line 358, in move
    raise univention.admin.uexceptions.ldapError, _('Moving not possible: old and new DN are identical.')
ldapError: Moving not possible: old and new DN are identical.

30.11.2011 23:25:21,734 LDAP        (INFO   ): Search AD with filter: (uSNCreated>=30859)
30.11.2011 23:25:21,735 LDAP        (INFO   ): Search AD with filter: (uSNChanged>=30859)
Comment 1 Stefan Gohmann univentionstaff 2013-11-26 08:32:20 CET
Sollte mit Bug #33482 behoben sein.

*** This bug has been marked as a duplicate of bug 33482 ***