Bug 25356 - DNS TXT records are not shown in UMC
DNS TXT records are not shown in UMC
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - DNS
UCS 4.0
All Linux
: P4 normal (vote)
: UCS 4.0-3-errata
Assigned To: Florian Best
Stefan Gohmann
:
: 36642 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-09 10:32 CET by Philipp Hahn
Modified: 2015-11-04 17:26 CET (History)
9 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Error handling, External feedback, Usability
Max CVSS v3 score:
best: Patch_Available+


Attachments
Patch (1.47 KB, patch)
2015-01-09 16:01 CET, Florian Best
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2011-12-09 10:32:41 CET
Die TXT-Records einer Zone werden in UMC nicht angezeigt.

Per "udm dns/txt_record list --superordinate zoneName=phahn.qa,cn=dns,dc=phahn,dc=qa" wird aber aufgelistet, das es "_kerberos" und "Philipp.Hahn" gibt.

Das Anlegen per UMC hat noch funktioniert, in der Suche danach waren sie aber schon nicht mehr zu sehen.
Comment 1 Philipp Hahn univentionstaff 2011-12-09 11:33:42 CET
Das Abfragen von TXT-DNS-Records funktioniert scheinbar auch nicht: Sie werden weder bei "host -t txt _kerberos.$(dnsdomainname)" noch bei einem "host -t axfr" angezeigt.

$ ldapsearch -xLLLH ldapi:/// relativeDomainName=_kerberos
dn: relativeDomainName=_kerberos,zoneName=phahn.qa,cn=dns,dc=phahn,dc=qa
objectClass: top
ObjectClass: dNSZone
objectClass: univentionObject
univentionObjectType: dns/txt_record
dNSTTL: 80600
tXTRecord: PHAHN.QA
relativeDomainName: _kerberos
zoneName: phahn.qa

Auf einem auf Hardware installierten Master erscheint der Eintrag aber bei der DNS-Abfrage, fehlt aber auch im UMC-Modul.
Comment 2 Philipp Hahn univentionstaff 2012-12-05 14:49:14 CET
Das tritt mit UCS-3.1 auch noch auf, sind aber eigentlich 2 Bugs:

1. Wenn man in UMC gezielt nach TXT-Records suchen lässt, werden sie dort auch gefunden. Bei einer Suche nach "Alle Objekttypen" werden sie nicht gefunden.

2. Mit Samba4 als Backend lassen sich keine TXT-Records abfragen: weder gezielt noch im Zone-Transfer werden sie gefunden.
Mit OpenLDAP als Backend funktioniert es.
Comment 3 Philipp Hahn univentionstaff 2012-12-10 14:32:42 CET
(In reply to comment #2)
> 2. Mit Samba4 als Backend lassen sich keine TXT-Records abfragen: weder gezielt
> noch im Zone-Transfer werden sie gefunden.
> Mit OpenLDAP als Backend funktioniert es.

Ggf. hängt das mit <https://bugzilla.samba.org/show_bug.cgi?id=8778> zusammen: Demnach speichert Samba4 TXT Records anders als früher. Fehlt dem S4-Connector ggf. ein Mapping dafür?

Die folgende Suchen finden den _kerberos TXT record auch in on OpenLDAP und nicht in Samba:

# ldbsearch -H ldapi:///var/lib/samba/private/ldap_priv/ldapi -b DC=phahn,DC=pt dn | grep kerb
dn: DC=_kerberos._tcp,DC=phahn.pt,CN=MicrosoftDNS,CN=System,DC=phahn,DC=pt
dn: DC=_kerberos._tcp.Default-First-Site-Name._sites.dc._msdcs,DC=phahn.pt,CN=MicrosoftDNS,CN=System,DC=phahn,DC=pt
dn: DC=_kerberos._tcp.dc._msdcs,DC=phahn.pt,CN=MicrosoftDNS,CN=System,DC=phahn,DC=pt
dn: DC=_kerberos._tcp.Default-First-Site-Name._sites,DC=phahn.pt,CN=MicrosoftDNS,CN=System,DC=phahn,DC=pt
dn: DC=_kerberos._udp,DC=phahn.pt,CN=MicrosoftDNS,CN=System,DC=phahn,DC=pt
dn: DC=_kerberos-adm._tcp,DC=phahn.pt,CN=MicrosoftDNS,CN=System,DC=phahn,DC=pt

# univention-ldapsearch  -xLLL -b dc=phahn,dc=pt dn | grep kerb
dn: cn=kerberos,dc=phahn,dc=pt
dn: krb5PrincipalName=default@PHAHN.PT,cn=kerberos,dc=phahn,dc=pt
dn: krb5PrincipalName=kadmin/admin@PHAHN.PT,cn=kerberos,dc=phahn,dc=pt
dn: krb5PrincipalName=kadmin/hprop@PHAHN.PT,cn=kerberos,dc=phahn,dc=pt
dn: relativeDomainName=_kerberos,zoneName=phahn.pt,cn=dns,dc=phahn,dc=pt <<<<<
dn: krb5PrincipalName=krbtgt/PHAHN.PT@PHAHN.PT,cn=kerberos,dc=phahn,dc=pt
dn: krb5PrincipalName=kadmin/changepw@PHAHN.PT,cn=kerberos,dc=phahn,dc=pt
dn: krb5PrincipalName=changepw/kerberos@PHAHN.PT,cn=kerberos,dc=phahn,dc=pt
dn: krb5PrincipalName=WELLKNOWN/ANONYMOUS@PHAHN.PT,cn=kerberos,dc=phahn,dc=pt
dn: relativeDomainName=_kerberos._tcp,zoneName=phahn.pt,cn=dns,dc=phahn,dc=pt
dn: relativeDomainName=_kerberos._udp,zoneName=phahn.pt,cn=dns,dc=phahn,dc=pt
dn: krb5PrincipalName=ldap/master.phahn.pt@PHAHN.PT,cn=kerberos,dc=phahn,dc=pt
dn: relativeDomainName=_kerberos-adm._tcp,zoneName=phahn.pt,cn=dns,dc=phahn,dc
dn: relativeDomainName=_kerberos._tcp.dc._msdcs,zoneName=phahn.pt,cn=dns,dc=ph
dn: relativeDomainName=_kerberos._tcp.Default-First-Site-Name._sites,zoneName=
dn: relativeDomainName=_kerberos._tcp.Default-First-Site-Name._sites.dc._msdcs
dn: krb5PrincipalName=ldap/backup.phahn.pt@PHAHN.PT,cn=kerberos,dc=phahn,dc=pt
Comment 4 Alexander Kläser univentionstaff 2014-11-13 14:50:44 CET
*** Bug 36642 has been marked as a duplicate of this bug. ***
Comment 5 Lutz Willek 2014-12-15 10:09:57 CET
(In reply to Philipp Hahn from comment #2)

Bug 1, also die fehlende Anzeige der TXT-Records, tritt auch noch genau so in UCS 4.0 auf. (Hier wird kein Samba verwendet) 
Version und Target Milestone des Bugs anpassen?

Eventuell auch in zwei verschiedene Bugreports splitten, da es ja wirklich zwei verschiedene Bugs sind?

mfg Willek
Comment 6 Alexander Kläser univentionstaff 2014-12-15 13:45:30 CET
(In reply to Lutz Willek from comment #5)
> Bug 1, also die fehlende Anzeige der TXT-Records, tritt auch noch genau so
> in UCS 4.0 auf. (Hier wird kein Samba verwendet) 
> Version und Target Milestone des Bugs anpassen?
> 
> Eventuell auch in zwei verschiedene Bugreports splitten, da es ja wirklich
> zwei verschiedene Bugs sind?
> 
> mfg Willek

Vielen Dank für ihr Feedback. Ich habe Versionsnummern angepasst und den Bug aufgesplittet.
Viele Grüße
A. Kläser
Comment 7 Florian Best univentionstaff 2015-01-09 16:01:26 CET
Created attachment 6590 [details]
Patch

Simple patch: just add the missing lookup for TXT records to forward zones.
Comment 8 Arvid Requate univentionstaff 2015-09-16 16:20:16 CEST
Note: TXT records are currently not synchronized by the S4-Connector.
The lookup generally works though:

bash# kinit --password-file=<(echo -n univention) Administrator

bash# nsupdate -v -g <<%EOF
zone $(ucr get domainname).
update add _kerberos.$(ucr get domainname).  900 IN TXT works
send
quit
%EOF

bash# host -t txt _kerberos
_kerberos.ar40i1.qa descriptive text "works"
Comment 9 Lutz Willek 2015-09-17 16:47:22 CEST
(In reply to Florian Best from comment #7)
> Created attachment 6590 [details]
> Patch
> 
> Simple patch: just add the missing lookup for TXT records to forward zones.

confirmed: patch works perfect.

Please would you like to add this simple patch to one of the next ucs errata updates?


Regards

Lutz Willek
Comment 10 Florian Best univentionstaff 2015-09-17 17:40:49 CEST
Patch has been applied and merged to UCS 4.1. YAML created.

2015-09-09-univention-directory-manager-modules.yaml:
r63820 | YAML Bug #25356

univention-directory-manager-modules (10.0.31-16):
r63818 | Bug #25356: add lookup of TXT records in dns/dns

univention-directory-manager-modules (11.0.1-1):
r63819 | Bug #25356: add lookup of TXT records in dns/dns
Comment 11 Stefan Gohmann univentionstaff 2015-10-03 15:44:49 CEST
Code Review: OK

YAML: OK

Tests: OK

Merge to 4.1: OK
Comment 12 Janek Walkenhorst univentionstaff 2015-11-04 17:26:37 CET
<http://errata.software-univention.de/ucs/4.0/357.html>