Bug 25368 - Crash von policykit1-kde direkt nach dem Login
Crash von policykit1-kde direkt nach dem Login
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: General
UCS 3.1
Other Linux
: P5 normal (vote)
: UCS 3.1-1
Assigned To: Lukas Walter
Felix Botner
:
: 29752 (view as bug list)
Depends on: 23864
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-09 11:55 CET by Florian Best
Modified: 2013-04-04 06:38 CEST (History)
5 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2011-12-09 11:55:49 CET
Das Problem ist gerade wieder bei einem Benutzeraccount aufgetreten, der nur
das Standard KDE4-Menu Profil aktiviert hatte.
Der fix wurde im /univention-kde-profiles/kde4-menu Desktop Profil gemacht. Es
ist sinnvoll dies (auch) in /usr/share/univention-kde-profiles/ucs-3.0 zu
machen.

+++ This bug was initially created as a clone of Bug #23864 +++

Created an attachment (id=3577)
Screenshot

Direkt nach dem Login (von z.B. Administrator) stürzt policykit1-kde
zuverlässig ab.
Comment 1 Philipp Hahn univentionstaff 2012-12-05 13:45:47 CET
Ist mit UCS-3.1 und User=Administrator immer noch so.
Comment 2 Lukas Walter univentionstaff 2013-03-05 14:01:09 CET
Der Fehler tritt wieder auf weil der Fix von Bug #23864 bewusst wieder rückgängig gemacht wurde da das Policy Kit unbedingt benötigt wird.

Die eigentliche Fehlerursache (dass der dbus keinen Zugriff auf die LDAP Benutzer hat) sollte aber behoben sein seit in dem UCR template für "/etc/libnss-ldap.conf" (aus univention-pam) binddn und bindpw gesetzt werden.

Damit das funktionieren kann muss aber das machine.secret bereits vorhanden sein - zum Zeitpunkt des letzten Commits auf das Template während der Installation durch das Joinskript 10univention-ldap-server.inst ist das jedoch nicht der Fall.

Um sicherzustellen, dass das Template in jedem Fall nochmal commited wird nachdem 10univention-ldap-server.inst ausgeführt wurde hat univention-pam jetz ein eigenes Join Skript in dem eben das getan wird: 11univention-pam.inst.

So sollte der Fehler nicht mehr auftreten.


univention-pam (6.0.12-1) unstable; urgency=low
  * added join script 11univention-pam.inst
  * commit UCR template for /etc/libnss-ldap.conf in join script
  (Bug #25368)

svn 39391
Comment 3 Stefan Gohmann univentionstaff 2013-03-08 09:24:30 CET
Bitte noch call_joinscript im postinst aufrufen.
Comment 4 Lukas Walter univentionstaff 2013-03-08 12:07:46 CET
univention-pam (6.0.13-2) unstable; urgency=low
  * call join script in postinst (Bug #25368)

svn 39484
Comment 5 Felix Botner univentionstaff 2013-03-12 12:13:08 CET
Fail kein Changelog Eintag (sonst OK)

OK, ich habe einen Master mit 3.1-1 frisch installiert, direkt nach dem ersten Start sah /etc/libnss-ldap.conf korrekt aus (bindpw war gesetzt). Bei einer Anmeldung als Administrator gab es keinen policyKit Fehler und die Uhrzeit konnte eingestellt werden.

(In reply to comment #3)
> Bitte noch call_joinscript im postinst aufrufen.

OK.
Comment 6 Lukas Walter univentionstaff 2013-03-12 13:16:23 CET
Changelogeintrag wurde hinzugefügt.
Comment 7 Felix Botner univentionstaff 2013-03-12 13:19:14 CET
OK
Comment 8 Stefan Gohmann univentionstaff 2013-03-25 19:57:11 CET
UCS 3.1-1 has been released: 
 http://download.univention.de/doc/release-notes-3.1-1_en.pdf
 http://download.univention.de/doc/release-notes-3.1-1.pdf

If this error occurs again, please use "Clone This Bug".
Comment 9 Stefan Gohmann univentionstaff 2013-04-04 06:38:31 CEST
*** Bug 29752 has been marked as a duplicate of this bug. ***