Bug 27662 - ucs-test Übernahme: 10_ldap
ucs-test Übernahme: 10_ldap
Status: CLOSED FIXED
Product: UCS Test
Classification: Unclassified
Component: LDAP
unspecified
Other Linux
: P5 normal (vote)
: UCS 3.2
Assigned To: Philipp Hahn
Stefan Gohmann
: interim-1
Depends on: 23527
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-19 18:22 CEST by Philipp Hahn
Modified: 2013-11-19 06:42 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2012-06-19 18:22:21 CEST
Folgende Tests müssen in ucs-test für UCS-3.0 geprüft und ggf. angepasst übernommen werden:

<svn+ssh://billy.knut.univention.de/var/svn/dev/branches/ucs-3.0/internal/ucs-test> → <svn+ssh://billy.knut.univention.de/var/svn/dev/branches/ucs-3.0/ucs/test/ucs-test>

scripts-10_ldap
debian/ucs-test-ldap.install
Comment 1 Stefan Gohmann univentionstaff 2012-12-04 13:27:25 CET
Diese Tests sollten übernommen und angepasst werden:
02check-permission-etc-ldap
02check-permission-etc-ldap-backup
02check-permission-etc-slave-join
05join_with_long_bind_dn
10slapd_stop_start
20schema-download
31ldapi
33slapcat_slapadd
40replication
41listener
55slapd-crash-1270
60failedldif
61getent_crash
62check_nscd_module
63univention-admingrp-user-passwordreset
64univention-admingrp-user-passwordreset-selfmodify
65univention-admingrp-user-passwordreset-ldapdiff
66univention-admingrp-user-passwordreset-grpingrp

Dieser Test kann entfernt werden:
32lanman

Hinweise zum neuen Framework:
http://wiki.univention.de/index.php?title=Ucs-test
https://forge.univention.org/bugzilla/show_bug.cgi?id=23527
Comment 2 Liam Schwez univentionstaff 2013-04-23 15:24:39 CEST
Tests were adapted to "ucs-test" framework according to requirements. http://wiki.univention.de/index.php?title=Ucs-test.

Tests "2check-permission-etc-ldap", "02check-permission-etc-ldap-backup", "02check-permission-etc-slave-join" were joined to one test "02check-permission-etc". This test is now written in Python and not in bash. The rest of the tests stayed in bash. 
 
Adjustments, improvements and bugfixes were implemented.

Test "62check_nscd_module" is obsolete since UCS 3.1. Test "62check_ldap_group_to_file" added instead which is checking the functionality 
of "NSS update script" instead of "nscd listener".

Tests "63univention-admingrp-user-passwordreset", "64univention-admingrp-user-passwordreset-selfmodify" and "66univention-admingrp-user-passwordreset-grpingrp" are checking ACL functionality.
Their execution is affected by a problem caused by ACLs (Bug 31142 opened).

All tests were stored in SVN:
<svn+ssh://billy.knut.univention.de/var/svn/dev/branches/ucs-3.1/ucs-3.1-2/test/ucs-test/tests/10_ldap/>
Comment 3 Stefan Gohmann univentionstaff 2013-06-12 08:15:20 CEST
The package ucs-test-ldap will now be built.

tests/10_ldap/02check-permission-etc:
I don't think this is right even it was already so in the old 2.4 tests:
*** BEGIN *** ['/usr/bin/python2.6', '02check-permission-etc'] ***
ERROR /etc/ldap-backup.secret has wrong group DC Backup Hosts but should be Slave Join
*** END *** 110 ***
/etc/ldap-backup.secret should be owned by the group DC Backup Hosts.

tests/10_ldap/05join_with_long_bind_dn: 
This does a lot of univention-join stuff again and the test will only be executed if the system is not joined. Would it not be better if we check only the functionality in a shorter environment? For example, we check what is the cause of the failure, for example a missing ldapsearch-wrapper, and check it in the code?

tests/10_ldap/41listener:
The test should check if any other object is written to the tempfile. 120 seconds is a lot of time. I think we should add more listener specific tests, for example if the replication is fast enough. I will create new bugs for that.
Comment 4 Stefan Gohmann univentionstaff 2013-06-14 07:42:49 CEST
(In reply to Stefan Gohmann from comment #3)
> The package ucs-test-ldap will now be built.
> 
> tests/10_ldap/02check-permission-etc:
> I don't think this is right even it was already so in the old 2.4 tests:
> *** BEGIN *** ['/usr/bin/python2.6', '02check-permission-etc'] ***
> ERROR /etc/ldap-backup.secret has wrong group DC Backup Hosts but should be
> Slave Join
> *** END *** 110 ***
> /etc/ldap-backup.secret should be owned by the group DC Backup Hosts.

I just fixed it, see also Bug #15557.
Comment 5 Stefan Gohmann univentionstaff 2013-06-15 14:23:57 CEST
test/ucs-test/tests/10_ldap/02check-permission-etc: 
The file /etc/slave-join.secret is not available on a DC Backup server. The old test case scripts-10_ldap/02check-permission-etc-slave-join was only executed on DC Master systems.
Comment 6 Stefan Gohmann univentionstaff 2013-06-19 11:24:56 CEST
(In reply to Stefan Gohmann from comment #5)
> test/ucs-test/tests/10_ldap/02check-permission-etc: 
> The file /etc/slave-join.secret is not available on a DC Backup server. The
> old test case scripts-10_ldap/02check-permission-etc-slave-join was only
> executed on DC Master systems.

This has been fixed while working on Bug #31680.
Comment 7 Philipp Hahn univentionstaff 2013-07-18 13:52:35 CEST
svn42527,42529,42535...42560: Lots up updates, mostly LDAP related, but also some general issues.

(In reply to Stefan Gohmann from comment #3)
> tests/10_ldap/02check-permission-etc:

fixed a mis-naming bug.

> tests/10_ldap/05join_with_long_bind_dn: 

moved to new section "join", which is not packaged and thus not run automatically.

> tests/10_ldap/41listener:

Two additional tests for replication were added: Bug #31721, Bug #31722
Comment 8 Stefan Gohmann univentionstaff 2013-08-15 13:38:49 CEST
OK, all tests have been copied.
Comment 9 Stefan Gohmann univentionstaff 2013-11-19 06:42:20 CET
UCS 3.2 has been released:
 http://docs.univention.de/release-notes-3.2-en.html
 http://docs.univention.de/release-notes-3.2-de.html

If this error occurs again, please use "Clone This Bug".