Bug 27685 - Traceback when selecting UMC module Users or listing objects with udm users/user list
Traceback when selecting UMC module Users or listing objects with udm users/u...
Status: CLOSED DUPLICATE of bug 25360
Product: UCS
Classification: Unclassified
Component: UMC - Users
UCS 3.0
Other Linux
: P5 normal (vote)
: UCS 3.0-2
Assigned To: Andreas Büsching
Florian Best
: interim-1
Depends on:
Blocks: 28223
  Show dependency treegraph
 
Reported: 2012-06-20 12:00 CEST by Roman Asendorf
Modified: 2013-02-25 12:23 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Asendorf univentionstaff 2012-06-20 12:00:25 CEST
Following traceback appears in CLI calling udm users/user list:

File '/usr/lib/pymodules/python2.6/notifier/threads.py', line 81, in _run
    tmp = self._function()
  File '/usr/lib/pymodules/python2.6/notifier/__init__.py', line 104, in __call__
    return self._function( *tmp, **self._kwargs )
  File '/usr/lib/pymodules/python2.6/univention/management/console/modules/udm/__init__.py', line 424, in _thread
    if module.module is None:

AttributeError: 'NoneType' object has no attribute 'module'
Comment 1 Andreas Büsching univentionstaff 2012-06-20 12:04:53 CEST
Wahrscheinlich liegt im (In reply to comment #0)
> Following traceback appears in CLI calling udm users/user list:
> 
> File '/usr/lib/pymodules/python2.6/notifier/threads.py', line 81, in _run
>     tmp = self._function()
>   File '/usr/lib/pymodules/python2.6/notifier/__init__.py', line 104, in
> __call__
>     return self._function( *tmp, **self._kwargs )
>   File
> '/usr/lib/pymodules/python2.6/univention/management/console/modules/udm/__init__.py',
> line 424, in _thread
>     if module.module is None:
> 
> AttributeError: 'NoneType' object has no attribute 'module'

Der Traceback kommt aus dem UMC-Backendprozess. Hast du hier was verwechselt? :-)
Comment 2 Andreas Büsching univentionstaff 2012-06-20 12:06:24 CEST
Der Traceback deutet darauf hin, dass es im LDAP ein Objekt gibt, dass der UDM nicht mehr identifizieren kann. Mit welcher Version ist das aufgetreten? 3.0-0 oder 3.0-1?
Comment 3 Roman Asendorf univentionstaff 2012-06-20 12:15:35 CEST
univention-ldapsearch shows following (anonymized) infos for user accounts:

# user1, users, domain.local
dn: uid=user1,cn=users,dc=domain,dc=local
uid: user1
krb5PrincipalName: user1@DOMAIN.LOCAL
objectClass: top
objectClass: person
objectClass: univentionPWHistory
objectClass: posixAccount
objectClass: shadowAccount
objectClass: univentionMail
objectClass: sambaSamAccount
objectClass: organizationalPerson
objectClass: inetOrgPerson
objectClass: krb5Principal
objectClass: krb5KDCEntry
objectClass: univentionObject
pwhistory: XXXXXXXXX
sambaAcctFlags: [U          ]
sambaPasswordHistory: XXXXXXXXXX
krb5MaxLife: 86400
cn: Firstname Lastname
userPassword:: XXXXXXXX
krb5Key:: XXXXXXXX
krb5Key:: XXXXXXXX
krb5Key:: XXXXXXXX
krb5Key:: XXXXXXXX
krb5Key:: XXXXXXXX
krb5Key:: XXXXXXXX
krb5MaxRenew: 604800
uidNumber: 2099
sambaLMPassword: XXXXXXXX
gecos: Firstname Lastname
sambaLogonScript: login_service.cmd
loginShell: /bin/bash
univentionObjectType: users/user
krb5KDCFlags: 126
gidNumber: 5014
sambaPwdLastSet: 1340185541
sambaNTPassword: XXXXXXXXXX
displayName: Firstname Lastname
sambaSID: S-1-5-21-2996864188-3427636799-1190481614-5220
krb5KeyVersionNumber: 1
sn: Lastname
homeDirectory: /home/domain/user1
givenName: Firstname
sambaPrimaryGroupSID: S-1-5-21-2996864188-3427636799-1190481614-513

# search result
search: 3
result: 0 Success

# numResponses: 2
# numEntries: 1
Comment 4 Roman Asendorf univentionstaff 2012-06-20 13:00:02 CEST
root@ucs-master:~# udm users/user list
Traceback (most recent call last):
  File "/usr/share/univention-directory-manager-tools/univention-cli-server", line 233, in doit
    output = univention.admincli.admin.doit(arglist)
  File "/usr/lib/pymodules/python2.6/univention/admincli/admin.py", line 1078, in doit
    out.append( 'DN: %s' % _2utf8( univention.admin.objects.dn (object ) ) )
  File "/usr/lib/pymodules/python2.6/univention/admincli/admin.py", line 243, in _2utf8
    return text.decode( 'iso-8859-1' )
AttributeError: 'NoneType' object has no attribute 'decode'
root@ucs-master:~#
Comment 5 Andreas Büsching univentionstaff 2012-06-20 13:30:02 CEST
(In reply to comment #4)
>     return text.decode( 'iso-8859-1' )
> AttributeError: 'NoneType' object has no attribute 'decode'

Das ist ein bekanntes Problem, das zu UCS 3.0-2 korrigiert wird

*** This bug has been marked as a duplicate of bug 25360 ***
Comment 6 Roman Asendorf univentionstaff 2012-06-20 14:38:26 CEST
(In reply to comment #5)
> (In reply to comment #4)
> >     return text.decode( 'iso-8859-1' )
> > AttributeError: 'NoneType' object has no attribute 'decode'
> 
> Das ist ein bekanntes Problem, das zu UCS 3.0-2 korrigiert wird
> 
> *** This bug has been marked as a duplicate of bug 25360 ***

Workaround at bug 25360 works.
Comment 7 Florian Best univentionstaff 2012-06-20 15:07:54 CEST
(In reply to comment #6)
> (In reply to comment #5)
> > (In reply to comment #4)
> > >     return text.decode( 'iso-8859-1' )
> > > AttributeError: 'NoneType' object has no attribute 'decode'
> > 
> > Das ist ein bekanntes Problem, das zu UCS 3.0-2 korrigiert wird
> > 
> > *** This bug has been marked as a duplicate of bug 25360 ***
> 
> Workaround at bug 25360 works.
Ok.

root@master:~# udm users/user list --filter uid=user1ABC21324 | grep ABC
uid=user1ABC21324
DN: uid=user1ABC21324,cn=users,dc=foo,dc=bar
  username: user1ABC21324
Comment 8 Stefan Gohmann univentionstaff 2012-07-20 15:24:38 CEST
UCS 3.0-2 has been released: 
  http://forum.univention.de/viewtopic.php?f=54&t=1905

If this error occurs again, please use "Clone This Bug".