Bug 27785 - Neuer GDB für Position Independent Executable (PIE)
Neuer GDB für Position Independent Executable (PIE)
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: General
UCS 3.0
All Linux
: P5 enhancement (vote)
: UCS 3.2-8-errata
Assigned To: Philipp Hahn
Stefan Gohmann
:
: 30808 (view as bug list)
Depends on:
Blocks: 28748
  Show dependency treegraph
 
Reported: 2012-07-02 15:24 CEST by Philipp Hahn
Modified: 2016-07-07 13:45 CEST (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Troubleshooting
Max CVSS v3 score:
hahn: Patch_Available+


Attachments
Disable BIND9 build hardening (1.20 KB, patch)
2012-07-02 15:25 CEST, Philipp Hahn
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2012-07-02 15:24:31 CEST
Der aktuelle BIND lässt sich nicht mehr mit unserem gdb-7.0 debuggen, weil BIND anscheinend mit aktivierten Build-Hardening-Flags übersetzt wird, was dazu führt, das /usr/sbin/named ein PIE ist.
<http://wiki.debian.org/Hardening/>

Nach Rücksprache mit Moritz ist BIND bereits aus Wheezy/Sid importiert, wo das Build-Hardening bereits standardmäßig aktiviert und besser getestet ist. Vermutlich macht es sinn, da bei uns wieder zu deaktivieren, weil in Squeeze die ganze Tool-Chain deutlich älter ist.
<http://packages.debian.org/search?keywords=bind9&searchon=sourcenames&suite=all&section=all>

Auf jeden Fall wird ein neuerer gdb (mindestens 7.1) benötigt, der dann solche PIEs wieder verarbeiten kann. Ein Test-Build des heutige Sid-GDBs (7.4.1-1.1) war ohne Probleme möglich.
Comment 1 Philipp Hahn univentionstaff 2012-07-02 15:25:26 CEST
Created attachment 4490 [details]
Disable BIND9 build hardening
Comment 2 Philipp Hahn univentionstaff 2012-07-02 15:54:46 CEST
Patch wurde nach Rücksprache mit Moritz eingespielt für Bug 25868:
svn10532, bind9_9.8.0.P4-1.97.201207021548

Ich laß den Bug für den neueren GDB bestehen.
Comment 3 Philipp Hahn univentionstaff 2012-11-16 11:36:10 CET
Unser gdb-7.0.1 ist defekt und lässt sich nicht für das Debuggen von Python-Programmen verenden.
Siehe <https://bugs.launchpad.net/ubuntu/+source/gdb/+bug/591023> und <http://bugs.python.org/issue8279?#msg102276>
Comment 4 Philipp Hahn univentionstaff 2013-03-18 12:27:36 CET
*** Bug 30808 has been marked as a duplicate of this bug. ***
Comment 5 Philipp Hahn univentionstaff 2016-06-23 15:56:48 CEST
(In reply to Philipp Hahn from comment #2)
> Patch wurde nach Rücksprache mit Moritz eingespielt für Bug 25868:
> svn10532, bind9_9.8.0.P4-1.97.201207021548
> 
> Ich laß den Bug für den neueren GDB bestehen.

That patch got disabled for UCS-3.2-7:
 3.2-0-0-ucs/1:9.8.4.dfsg.P1-6+nmu2+deb7u6-errata3.2-6/021_27785_bind9-hardening.patch.DISABLED

Thus bind9 is again undebuggable!

core-file was created by "kill -SEGV" (without "00026-prlimit.c")

Ticket #2016061421000591
Comment 6 Philipp Hahn univentionstaff 2016-07-01 13:13:08 CEST
Cherry picked gdb[46706] from 3.0-0-0[72]/wheezy[290] to 3.2[74]/errata3.2-8[418]

Package: gdb
Version: 7.4.1-3.26.201607011222
Branch: ucs_3.2-0
Scope: errata3.2-8

r70765 | Bug #27785 gdb: YAML 3.2-8
 gdb.yaml
Comment 7 Philipp Hahn univentionstaff 2016-07-04 09:52:13 CEST
(In reply to Philipp Hahn from comment #6)
> Cherry picked gdb[46706] from 3.0-0-0[72]/wheezy[290] to
> 3.2[74]/errata3.2-8[418]
> 
> Package: gdb
> Version: 7.4.1-3.26.201607011222
> Branch: ucs_3.2-0
> Scope: errata3.2-8
> 
> r70765 | Bug #27785 gdb: YAML 3.2-8
>  gdb.yaml

I didn't check for new dependencies from unmaintained. I'm okay with releasing gdb as unmaintained, as it is not a primary component of UCS and unmaintained is needed for development and debugging anyway.
Comment 8 Stefan Gohmann univentionstaff 2016-07-06 17:18:33 CEST
(In reply to Philipp Hahn from comment #7)
> (In reply to Philipp Hahn from comment #6)
> > Cherry picked gdb[46706] from 3.0-0-0[72]/wheezy[290] to
> > 3.2[74]/errata3.2-8[418]
> > 
> > Package: gdb
> > Version: 7.4.1-3.26.201607011222
> > Branch: ucs_3.2-0
> > Scope: errata3.2-8
> > 
> > r70765 | Bug #27785 gdb: YAML 3.2-8
> >  gdb.yaml
> 
> I didn't check for new dependencies from unmaintained. I'm okay with
> releasing gdb as unmaintained, as it is not a primary component of UCS and
> unmaintained is needed for development and debugging anyway.

No new dependencies which are not maintained.

Tests: OK

YAML: OK
Comment 9 Janek Walkenhorst univentionstaff 2016-07-07 13:45:54 CEST
<http://errata.software-univention.de/ucs/3.2/441.html>