Bug 28574 - [system-setup] Validierung endet in Endlosschleife
[system-setup] Validierung endet in Endlosschleife
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - Basic settings
UCS 3.0
Other Linux
: P3 normal (vote)
: UCS 3.2
Assigned To: Florian Best
Dirk Wiesenthal
: interim-1
: 31880 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-17 15:39 CEST by Florian Best
Modified: 2013-12-09 17:24 CET (History)
4 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Troubleshooting
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2012-09-17 15:39:09 CEST
Wenn eine lange hostname/fqdn/ldap_base/domainname oder windows_domain angegeben wird endet der validate command in einer Endlosschleife und verhindert weitere Aktionen im UMC-Modul (bis zum http timeout).

# umc-command -U root setup/validate -e -o '{"values":{"timezone":"America/New_York","locale/keymap":"us","locale":"en_US.UTF-8:UTF-8 de_DE.UTF-8:UTF-8","locale/default":"en_US.UTF-8:UTF-8","ldap/base":"dc=sdfasdasdfsssssssssssssfasdfasdfasdf,dc=asdfasdfasdfasasddddddddd","windows/domain":"SDFASDASDFSSSSSSSSSSSSSFASDFASDFASDF","hostname":"asdfasdfasdfasdfasdfasdfasdfa","domainname":"sdfasdasdfsssssssssssssfasdfasdfasdf.asdfasdfasdfasasddddddddd","components":"univention-s4-connector:univention-samba4 samba:univention-samba"}}'
Comment 1 Florian Best univentionstaff 2013-07-04 15:17:57 CEST
This was the same as in Bug #24888 for the installer.

The 2 regex's have been optimized.
Comment 2 Florian Best univentionstaff 2013-07-08 13:42:37 CEST
The fix allows 'foo..bar', See Bug #24888 comment 6
Comment 3 Florian Best univentionstaff 2013-07-08 13:51:29 CEST
(In reply to Florian Best from comment #2)
> The fix allows 'foo..bar', See Bug #24888 comment 6
Fixed again, univention-system-setup (7.0.17-1)
Comment 4 Florian Best univentionstaff 2013-07-19 08:07:24 CEST
*** Bug 31880 has been marked as a duplicate of this bug. ***
Comment 5 Dirk Wiesenthal univentionstaff 2013-08-06 16:12:02 CEST
VERIFIED

But I REOPEN the bug:

While fixing this the is_windowsdomainname.RE changed in quality and I do not see the reason why. In 3.1-1 a dot was allowed and now it is not (may cause problems when joining new computers to an existing dot-containing windows domain). Also the name length must be at least 2 now and it was 1. Please RESOLVE this bug if you double checked that this is correct.

See http://support.microsoft.com/kb/909264/en-us
Comment 6 Florian Best univentionstaff 2013-08-07 15:12:17 CEST
The feature to have a dot in the windows domain was removed by Bug #26027
The installer code currently also disallows this (base/univention-installer/installer/modules/50_basis.py +308).

A one char length windows domain can now be created.
univention-system-setup (7.0.25-1)
Comment 7 Dirk Wiesenthal univentionstaff 2013-08-08 14:32:10 CEST
Changeset: Ok
Comment 8 Stefan Gohmann univentionstaff 2013-11-19 06:42:14 CET
UCS 3.2 has been released:
 http://docs.univention.de/release-notes-3.2-en.html
 http://docs.univention.de/release-notes-3.2-de.html

If this error occurs again, please use "Clone This Bug".