Bug 29201 - Traceback in udm/__init__.py line 426: 'NoneType' object has no attribute 'module'
Traceback in udm/__init__.py line 426: 'NoneType' object has no attribute 'm...
Status: RESOLVED DUPLICATE of bug 34680
Product: UCS
Classification: Unclassified
Component: UDM (Generic)
UCS 3.0
All Linux
: P3 normal (vote)
: UCS 3.2-x
Assigned To: UDM maintainers
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-12 11:04 CET by Arvid Requate
Modified: 2015-03-17 15:07 CET (History)
5 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Ticket number:
Bug group (optional): Cleanup, Troubleshooting
Max CVSS v3 score:
klaeser: Patch_Available+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arvid Requate univentionstaff 2012-11-12 11:04:14 CET
Der an Bug 28627 Comment 3 notierte Traceback bei der Bedienung der UMC wurde auch aus einer Testumgebung mit der c't Edition (auf Basis von UCS 3.0-2) gemeldet:


+++ This bug was initially created as a clone of Bug #28627 Comment 3 +++

File '/usr/lib/pymodules/python2.6/notifier/threads.py', line 82, in _run
    tmp = self._function()
  File '/usr/lib/pymodules/python2.6/notifier/__init__.py', line 104, in
__call__
    return self._function( *tmp, **self._kwargs )
  File
'/usr/lib/pymodules/python2.6/univention/management/console/modules/udm/__init__.py',
line 426, in _thread
    if module.module is None:
AttributeError: 'NoneType' object has no attribute 'module'
Comment 1 Arvid Requate univentionstaff 2012-11-12 11:13:16 CET
Da könnte auch was am logging verbessert werden, dieser Traceback ist in keiner der Logdateien aufgezeichnet.
Comment 2 Alexander Kläser univentionstaff 2012-12-04 10:11:03 CET
(In reply to comment #0)
> Der an Bug 28627 Comment 3 notierte Traceback bei der Bedienung der UMC wurde
> auch aus einer Testumgebung mit der c't Edition (auf Basis von UCS 3.0-2)
> gemeldet:
> 
> 
> +++ This bug was initially created as a clone of Bug #28627 Comment 3 +++
> 
> File '/usr/lib/pymodules/python2.6/notifier/threads.py', line 82, in _run
>     tmp = self._function()
>   File '/usr/lib/pymodules/python2.6/notifier/__init__.py', line 104, in
> __call__
>     return self._function( *tmp, **self._kwargs )
>   File
> '/usr/lib/pymodules/python2.6/univention/management/console/modules/udm/__init__.py',
> line 426, in _thread
>     if module.module is None:
> AttributeError: 'NoneType' object has no attribute 'module'

Die Zeile müsste lauten:

  if not module:
Comment 3 Alexander Kläser univentionstaff 2012-12-04 10:13:02 CET
(In reply to comment #2)
> Die Zeile müsste lauten:
> 
>   if not module:

Folgende Zeilen (3.1 RC) scheinen den Fehler zu beinhalten: 472, 959
Comment 4 Florian Best univentionstaff 2015-03-17 15:07:40 CET
Fixed at Bug #34680.

*** This bug has been marked as a duplicate of bug 34680 ***