Bug 29610 - Suche nach Paketen wirft einen Fehler
Suche nach Paketen wirft einen Fehler
Status: CLOSED DUPLICATE of bug 30967
Product: UCS
Classification: Unclassified
Component: UMC - Software monitor
UCS 3.0
Other Linux
: P4 normal (vote)
: UCS 3.2
Assigned To: Florian Best
Alexander Kläser
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-06 15:47 CET by Jascha Geerds
Modified: 2013-11-19 06:44 CET (History)
1 user (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Flags outvoted after Product Owner Review:
Ticket number:
Bug group (optional): Troubleshooting
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jascha Geerds univentionstaff 2012-12-06 15:47:46 CET
Wenn man das Software-Monitor UMC-Modul öffnet und in der Combo-Box "Suche nach" den Eintrag "Systemname" auswählt, erscheinen weitere Suchkriterien. Klickt man nun auf "suchen" wird folgender Traceback angezeigt:

Die Ausführung des Kommandos pkgdb/query ist fehlgeschlagen:

-----
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/univention/management/console/modules/__init__.py", line 204, in execute
    func( request )
  File "/usr/lib/pymodules/python2.6/univention/management/console/modules/pkgdb/__init__.py", line 317, in query
    if cmp(self._last_query, request.options) == 0:
AttributeError: 'Instance' object has no attribute '_last_query'
-----

Der Fehler tritt auch bei anderen Suchoptionen auf.
Comment 1 Jascha Geerds univentionstaff 2012-12-06 15:55:17 CET
Das Problem hing damit zusammen, dass `univention-pkgdb` nicht installiert war. Nachdem das Paket installiert wurde, funktioniert die Suche problemlos.

Ich denke es ist aber dennoch recht ungünstig, dass der Benutzer direkt in einen Traceback reinläuft. Das UMC-Modul sollte `univention-pkgdb` als Abhängigkeit haben oder alternativ sollte ein Dialog im UMC-Modul angezeigt werden, welcher darauf hinweist, dass kein `univention-pkgdb` installiert wird
Comment 2 Florian Best univentionstaff 2013-07-04 10:51:04 CEST
univention-pkgdb (=VERSION) has been added as dependency to the pkgdb UMC module.
Comment 3 Florian Best univentionstaff 2013-07-19 08:44:17 CEST

*** This bug has been marked as a duplicate of bug 30967 ***
Comment 4 Alexander Kläser univentionstaff 2013-08-23 17:05:13 CEST
OK
Comment 5 Stefan Gohmann univentionstaff 2013-11-19 06:44:32 CET
UCS 3.2 has been released:
 http://docs.univention.de/release-notes-3.2-en.html
 http://docs.univention.de/release-notes-3.2-de.html

If this error occurs again, please use "Clone This Bug".