Bug 30077 - Dependencies in the App Center
Dependencies in the App Center
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: App Center
UCS 3.1
All Linux
: P2 enhancement (vote)
: UCS 3.2
Assigned To: Dirk Wiesenthal
Stefan Gohmann
: interim-2
: 29599 (view as bug list)
Depends on: 32163
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-21 08:18 CET by Kevin Dominik Korte
Modified: 2013-11-19 06:44 CET (History)
5 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Further conceptual development
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Dominik Korte univentionstaff 2013-01-21 08:18:00 CET
It might be helpful if the App Center would support dependencies between different APPs in addition to Conflicts.

For example a clb. DV. App would certainly depend on UCC, but currently there is no way to reflect this in the ini file.
Comment 1 Alexander Kläser univentionstaff 2013-01-21 09:56:33 CET
Yes, definitively! Something we were thinking about, as well, these days :) .
Comment 2 Stefan Gohmann univentionstaff 2013-02-28 21:03:40 CET
I think it is not required for 3.1-1.
Comment 3 Stefan Gohmann univentionstaff 2013-04-03 06:06:18 CEST
*** Bug 29599 has been marked as a duplicate of this bug. ***
Comment 4 Stefan Gohmann univentionstaff 2013-06-11 08:10:18 CEST
We should provide only a simple dependency on app layer.
Comment 5 Florian Best univentionstaff 2013-07-25 14:40:19 CEST
Bug 29599 comment 2 says to also adapt the documentation of the ini file.
Comment 6 Dirk Wiesenthal univentionstaff 2013-07-29 11:28:46 CEST
(In reply to Stefan Gohmann from comment #4)
> We should provide only a simple dependency on app layer.

What about versions (e.g. RequiredApps: ucc=1.1)?

Shall the corresponding apps be installed automatically or shall we just point the user to these apps and he has to install them manually?

I think it would be better to just point the user to it. Otherwise we have to think of a lot of details like license agreement and get problems in the future, e.g. if we want to support some initial pre-install-ucr-variables-wizard.
Comment 7 Dirk Wiesenthal univentionstaff 2013-07-29 14:33:24 CEST
Added a very simple implementation in:
  univention-management-console-module-appcenter 3.0.10-1.155.201307291423

This affects only cannot_install_reason() and cannot_uninstall_reason(). If someone really wants to install the application, he is still able to do so (e.g. via univention-add-app). This is more of a frontend fix which disables certain buttons.

If any application is mentioned in RequiredApps of the ini and this application is not yet installed, the install button is not shown and a message says: "%s requires the following Applications. Install them first."

If self is mentioned in any application's ini file as RequiredApps and this application is installed, the uninstall button is not shown and a message says: "%s is required for the following Applications to work. Uninstall them first."
Comment 8 Stefan Gohmann univentionstaff 2013-08-06 11:35:17 CEST
(In reply to Dirk Wiesenthal from comment #7)
> If any application is mentioned in RequiredApps of the ini and this
> application is not yet installed, the install button is not shown and a
> message says: "%s requires the following Applications. Install them first."

Is it possible to show it in a pop up dialog?
Comment 9 Dirk Wiesenthal univentionstaff 2013-08-06 12:05:42 CEST
(In reply to Stefan Gohmann from comment #8)
> (In reply to Dirk Wiesenthal from comment #7)
> > If any application is mentioned in RequiredApps of the ini and this
> > application is not yet installed, the install button is not shown and a
> > message says: "%s requires the following Applications. Install them first."
> 
> Is it possible to show it in a pop up dialog?

Yes, but it is currently placed where also ConflictedApps or insufficient RAM show up. So it seems to be the right place - or we revise the overall layout.

Do you mean "Install" should not be hidden but when clicking on it the popup should be shown?

If you want this message to appear somewhere else I suggest placing all other "prohibiting messages" there, too. And then it should be another bug.
Comment 10 Stefan Gohmann univentionstaff 2013-08-06 13:24:54 CEST
(In reply to Dirk Wiesenthal from comment #9)
> Do you mean "Install" should not be hidden but when clicking on it the popup
> should be shown?

Yes.

> If you want this message to appear somewhere else I suggest placing all
> other "prohibiting messages" there, too. And then it should be another bug.

Yes: Bug #32163.
Comment 11 Stefan Gohmann univentionstaff 2013-08-15 10:15:59 CEST
(In reply to Dirk Wiesenthal from comment #9)
> (In reply to Stefan Gohmann from comment #8)
> > (In reply to Dirk Wiesenthal from comment #7)
> > > If any application is mentioned in RequiredApps of the ini and this
> > > application is not yet installed, the install button is not shown and a
> > > message says: "%s requires the following Applications. Install them first."
> > 
> > Is it possible to show it in a pop up dialog?
> 
> Yes, but it is currently placed where also ConflictedApps or insufficient
> RAM show up. So it seems to be the right place - or we revise the overall
> layout.

I've looked again at this issue. I think we should solve it together with Bug #32163 otherwise the usability is not OK.

The pop up dialog should include a link to the other App.
Comment 12 Dirk Wiesenthal univentionstaff 2013-09-06 18:33:42 CEST
Looks better now with Bug#32163 fixed. Link to (the first of possibly many) app is available
Comment 13 Stefan Gohmann univentionstaff 2013-09-23 16:54:48 CEST
Changelog: OK

Tests: OK (z-push now depends on zarafa)

Documentation: Fail - it should be documented in the developer guide
Comment 14 Dirk Wiesenthal univentionstaff 2013-09-24 13:30:06 CEST
(In reply to Stefan Gohmann from comment #13)
> Changelog: OK
> 
> Tests: OK (z-push now depends on zarafa)
> 
> Documentation: Fail - it should be documented in the developer guide

It already is: http://docs.univention.de/developer-reference-3.2.html#app:iniFile (RequiredApps)
Comment 15 Stefan Gohmann univentionstaff 2013-09-24 13:54:42 CEST
(In reply to Dirk Wiesenthal from comment #14)
> (In reply to Stefan Gohmann from comment #13)
> > Changelog: OK
> > 
> > Tests: OK (z-push now depends on zarafa)
> > 
> > Documentation: Fail - it should be documented in the developer guide
> 
> It already is:
> http://docs.univention.de/developer-reference-3.2.html#app:iniFile
> (RequiredApps)

I see ..

→ Verified.
Comment 16 Stefan Gohmann univentionstaff 2013-11-19 06:44:28 CET
UCS 3.2 has been released:
 http://docs.univention.de/release-notes-3.2-en.html
 http://docs.univention.de/release-notes-3.2-de.html

If this error occurs again, please use "Clone This Bug".