Bug 30163 - Customisation of SSH host keys
Customisation of SSH host keys
Status: CLOSED FIXED
Product: Univention Corporate Client (UCC)
Classification: Unclassified
Component: Image management
unspecified
Other Linux
: P5 normal
: UCC 1.0-errata
Assigned To: Erik Damrose
Felix Botner
:
: 23291 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-24 13:51 CET by Moritz Muehlenhoff
Modified: 2013-05-03 15:48 CEST (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Moritz Muehlenhoff univentionstaff 2013-01-24 13:51:58 CET
The SSH host keys of downloaded images should be individualised in a similar way as it's already done for the root password.
Comment 1 Stefan Gohmann univentionstaff 2013-04-11 06:50:59 CEST
I think it is important to fix it.
Comment 2 Erik Damrose univentionstaff 2013-04-12 13:38:11 CEST
the host key should also be added to the persistent files
Comment 3 Erik Damrose univentionstaff 2013-04-17 16:25:00 CEST
Hostkeys are recreated during the client join. The hostkeys are added to the persistent files. New key generation according to http://wiki.debian.org/SSLkeys#OpenSSH_.28Server.29

Fixed in: univention-ucc-join 1.1.16-6.52.201304171617
yaml: 2013-04-02-univention-ucc-join.yaml
Comment 4 Felix Botner univentionstaff 2013-04-23 12:51:24 CEST
OK - YAML

OK - ssh keys are recreated during join
     ssh keys are added to persistent files
Comment 5 Janek Walkenhorst univentionstaff 2013-04-24 17:26:22 CEST
http://errata.univention.de/ucc/1.0/3.html
Comment 6 Erik Damrose univentionstaff 2013-05-03 15:48:54 CEST
*** Bug 23291 has been marked as a duplicate of this bug. ***