Bug 30190 - Attributes not defined with SUBSTR caseIgnoreSubstringsMatch cannot be searched
Attributes not defined with SUBSTR caseIgnoreSubstringsMatch cannot be searched
Status: RESOLVED DUPLICATE of bug 37904
Product: UCS
Classification: Unclassified
Component: UDM (Generic)
UCS 3.1
Other Linux
: P5 normal (vote)
: ---
Assigned To: UMC maintainers
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-28 15:22 CET by Dirk Wiesenthal
Modified: 2018-04-13 13:29 CEST (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Wiesenthal univentionstaff 2013-01-28 15:22:52 CET
Attributes that were not defined in the schema-file as:
	SUBSTR caseIgnoreSubstringsMatch

cannot be searched: Since UCS 3.1 asterisks are automatically added to the search filter:

Search for "user" -> Search for "*user*"

This means that attributes without the SUBSTR definition will not be found even if one searches for exactly the name as in LDAP.

This also holds for third-party-extensions.
Comment 1 Alexander Kläser univentionstaff 2013-04-19 10:46:44 CEST

*** This bug has been marked as a duplicate of bug 30533 ***
Comment 2 Florian Best univentionstaff 2015-05-08 17:23:34 CEST

*** This bug has been marked as a duplicate of bug 37904 ***