Bug 30358 - XenApp session script does not display firefox in fullscreen during login
XenApp session script does not display firefox in fullscreen during login
Status: CLOSED FIXED
Product: Univention Corporate Client (UCC)
Classification: Unclassified
Component: End user applications
unspecified
Other Linux
: P5 normal
: UCC 2.0
Assigned To: Moritz Muehlenhoff
Felix Botner
: interim-2
: 30255 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-08 14:32 CET by Erik Damrose
Modified: 2014-06-12 09:20 CEST (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
Patch to display firefox fullscreen and hide 'know your rights' message (4.24 KB, patch)
2013-02-26 16:25 CET, Erik Damrose
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Damrose univentionstaff 2013-02-08 14:32:38 CET
When the XenApp session script is started with autologin, firefox is not shown fullscreen, and with the metacity window borders.
Comment 1 Moritz Muehlenhoff univentionstaff 2013-02-08 14:42:55 CET
We would need to implement a similar hack as for OpenBox in Metacity.
Comment 2 Erik Damrose univentionstaff 2013-02-26 16:25:20 CET
Created attachment 5097 [details]
Patch to display firefox fullscreen and hide 'know your rights' message

I added a patch to address this issue and to remove the 'know your rights' message
Comment 3 Moritz Muehlenhoff univentionstaff 2013-12-17 08:32:10 CET
*** Bug 30255 has been marked as a duplicate of this bug. ***
Comment 4 Moritz Muehlenhoff univentionstaff 2014-04-04 10:37:23 CEST
Current Firefox (28) no longer displays the "You your rights" popup.

The devilspie configuration was integrated and the Citrix session is now correctly running in fullscreen if the auto-login is used. 

Note for QA: If the XenApp sesion is selected in LightDM fullscren was correctly enabled out of the box anyway. This change applies to running the XenApp session script with the autologin user, i.e. you need to set

lightdm/autologin: yes
lightdm/autologin/session: XenApp
Comment 5 Felix Botner univentionstaff 2014-04-28 17:10:29 CEST
OK - fullscreen mode
OK - changelog
Comment 6 Moritz Muehlenhoff univentionstaff 2014-06-12 09:20:07 CEST
UCC 2.0 has been released:
 http://docs.univention.de/release-notes-ucc-2.0.html

If this error occurs again, please use "Clone This Bug".