Bug 30420 - missing settings/ucc_session objects for lxde, ucc and ucc-remote
missing settings/ucc_session objects for lxde, ucc and ucc-remote
Status: CLOSED FIXED
Product: Univention Corporate Client (UCC)
Classification: Unclassified
Component: UCS Integration
unspecified
Other Linux
: P5 normal
: UCC 1.0-errata
Assigned To: Felix Botner
Erik Damrose
:
: 29962 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-13 13:30 CET by Felix Botner
Modified: 2014-05-23 14:42 CEST (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Botner univentionstaff 2013-02-13 13:30:30 CET
lxde, ucc and ucc-remote sessions are not selectable in "Force this session for user logins" for a user policy. The corresponding settings/ucc_session objects are missing

(see ucc-management-integration/30univention-corporate-client-schema.inst)
Comment 1 Moritz Muehlenhoff univentionstaff 2013-02-13 14:18:46 CET
These sessions can be registered manually in cn=univention. Documentation on how to do this has been added to the UCC manual.
Comment 2 Felix Botner univentionstaff 2013-04-03 09:27:16 CEST
Added settings/ucc_session objects (ucc, ucc-remote, lxde) to join script ucc-management-integration (ucc-integration) and modified force-user-session in univention-lightdm (ucc) so that a lxde session can forced.

2013-04-02-univention-lightdm.yaml
2013-04-02-ucc-management-integration.yaml
Comment 3 Erik Damrose univentionstaff 2013-04-10 17:39:08 CEST
Bugfix: 
- ucc, ucc terminal server and lxde are available OK
- each session is forceable on ucc clients OK
- if session script is not available the user-chosen sessionscript is started OK

YAML: OK
Comment 4 Janek Walkenhorst univentionstaff 2013-04-24 17:26:22 CEST
http://errata.univention.de/ucc/1.0/2.html
Comment 5 Moritz Muehlenhoff univentionstaff 2014-05-23 14:42:46 CEST
*** Bug 29962 has been marked as a duplicate of this bug. ***