Bug 30834 - Exam mode: collect / test GPOs
Exam mode: collect / test GPOs
Status: CLOSED FIXED
Product: UCS@school
Classification: Unclassified
Component: Samba 4
UCS@school 3.1
Other Linux
: P5 normal (vote)
: UCS@school 3.1 R2
Assigned To: Arvid Requate
Florian Best
: interim-1
: 31583 (view as bug list)
Depends on:
Blocks: 31583
  Show dependency treegraph
 
Reported: 2013-03-20 11:53 CET by Sönke Schwardt-Krummrich
Modified: 2013-06-07 21:39 CEST (History)
1 user (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
deny-and-allow-workstation-logons.txt (3.01 KB, text/plain)
2013-04-24 16:32 CEST, Arvid Requate
Details
denycmd.txt (680 bytes, text/plain)
2013-04-24 16:32 CEST, Arvid Requate
Details
software-restriction-policies-etc.txt (5.09 KB, text/plain)
2013-04-29 18:06 CEST, Arvid Requate
Details
software-restriction-policies-etc.txt (rev1) (5.33 KB, text/plain)
2013-04-29 18:19 CEST, Arvid Requate
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sönke Schwardt-Krummrich univentionstaff 2013-03-20 11:53:21 CET
One of the main parts of the exam mode is a collection of Windows GPOs activated together with the exam mode for the involved users/clients.

A reasonable list of GPOs for the exam mode shall be arranged, tested and documented.

Desired features:
- force proxy settings for all browsers
- disable USB storage devices
- limit available applications
- ...
Comment 2 Arvid Requate univentionstaff 2013-04-24 16:30:39 CEST
- force proxy settings for all browsers: See ADMX templates and GPO configuration instructions on Bug 30835 Comment 1.
Comment 3 Arvid Requate univentionstaff 2013-04-24 16:32:09 CEST
Created attachment 5193 [details]
deny-and-allow-workstation-logons.txt
Comment 4 Arvid Requate univentionstaff 2013-04-24 16:32:30 CEST
Created attachment 5194 [details]
denycmd.txt
Comment 5 Arvid Requate univentionstaff 2013-04-29 18:06:47 CEST
Created attachment 5205 [details]
software-restriction-policies-etc.txt
Comment 6 Arvid Requate univentionstaff 2013-04-29 18:19:01 CEST
Created attachment 5206 [details]
software-restriction-policies-etc.txt  (rev1)

An additional note with links to MS documentation about Software Restriction Policies was added together with a disclaimer regarding non-completeness of the examples given.
Comment 7 Arvid Requate univentionstaff 2013-04-30 19:54:12 CEST
All GPO settings collected here and on Bug 30835 are now gathered as examples into a section within the general chapter about the Exam Mode in the UCS@school  administrator manual (schoolexam-de.xml).
Comment 8 Arvid Requate univentionstaff 2013-05-06 21:33:24 CEST
The documentation was updated according to the test results.
Not that errata Bug 31272 needs to be fixed for the security filter based targeting of GPO evaluation.
Comment 9 Florian Best univentionstaff 2013-05-30 14:27:46 CEST
The GPO templates exists, are working and are correctly documented.
Comment 10 Arvid Requate univentionstaff 2013-05-30 17:52:58 CEST
*** Bug 31583 has been marked as a duplicate of this bug. ***
Comment 11 Sönke Schwardt-Krummrich univentionstaff 2013-06-07 21:39:19 CEST
UCS@school 3.1 R2 has been released:
http://download.univention.de/doc/release-notes-ucsschool-3.1-rev2.pdf

If this error occurs again, please use "Clone This Bug".