Bug 30852 - Unjoin scripts for UCC
Unjoin scripts for UCC
Status: CLOSED FIXED
Product: Univention Corporate Client (UCC)
Classification: Unclassified
Component: UCS Integration
unspecified
Other Linux
: P5 normal
: UCC 2.0
Assigned To: Alexander Kläser
Moritz Muehlenhoff
: interim-3
: 30418 34502 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-21 14:17 CET by Moritz Muehlenhoff
Modified: 2014-06-12 09:20 CEST (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Moritz Muehlenhoff univentionstaff 2013-03-21 14:17:44 CET
It should be documented how UCC images can be removed from the list of registered images.

(They are stored in cn=univention -> UCC -> Images)
Comment 1 Moritz Muehlenhoff univentionstaff 2013-12-18 09:25:31 CET
Starting with UCS 3.2 UCS supports unjoin scripts: The image generation should create unjoin scripts which deregister the images.
Comment 2 Moritz Muehlenhoff univentionstaff 2013-12-18 09:49:07 CET
*** Bug 30418 has been marked as a duplicate of this bug. ***
Comment 3 Moritz Muehlenhoff univentionstaff 2014-04-09 09:28:48 CEST
*** Bug 34502 has been marked as a duplicate of this bug. ***
Comment 4 Lukas Walter univentionstaff 2014-05-08 17:10:20 CEST
As discussed with Moritz, an unjoin script has been added to univention-coporate-client-schema.

It unregister all UCC images from LDAP.


ucc-management-integration 2.0.8-1.70.201405081708 (svn 50029)
Changelog: svn 50031

QA: Uninstall a current version of univention-corporate-client-schema on an UCC server and check whether all images are removed from LDAP.
Comment 5 Lukas Walter univentionstaff 2014-05-08 17:27:30 CEST
The unjoin script should verify wheter it was executed on the last UCC server in the domain before removing the images from LDAP -> REOPENED
Comment 6 Lukas Walter univentionstaff 2014-05-09 15:15:01 CEST
(In reply to Lukas Walter from comment #5)
> The unjoin script should verify wheter it was executed on the last UCC
> server in the domain before removing the images from LDAP -> REOPENED

univention-corporate-client-schema join script will register an "UCC" service at the local host computer object, which will be unregistered in the unjoin script.

If it was the last UCC service entry in the domain, the images are removed from LDAP as well.


ucc-management-integration 2.0.8-2.71.201405091516 (svn 50093)
Comment 7 Alexander Kläser univentionstaff 2014-05-21 12:42:17 CEST
The following points have been adjusted:

* The association with schema package was wrong as the schema package usually are not uninstalled. I moved the unjoin script into ucc-server.

* From the developer's guide:
"To reverse the order of the unjoin scripts in comparison to the corresponding join scripts, the number of the unjoin script should be 100 minus the number of the corresponding join script."
... and ...
"As of UCS 3.1 .inst and .uinst are not distinguishable in the UMC Join module by the user. Therefore it is important to use the -uninstall suffix to give users a visual hint."
→ the unjoin script should be named 70univention-corporate-client-uninstall.uinst

* As discussed, the unjoin script now only removes the service entry


ucc-server (1.0.1-1):
* Bug #30852: move unjoin script from integration package in ucc-server

ucc-management-integration (2.0.11-1):
* Bug #30852: move unjoin script into ucc-server package
Comment 8 Moritz Muehlenhoff univentionstaff 2014-05-21 14:14:37 CEST
Ok, the UCC service is correctly removed from the services list when uninstalling the UCC app.
Comment 9 Moritz Muehlenhoff univentionstaff 2014-06-12 09:20:10 CEST
UCC 2.0 has been released:
 http://docs.univention.de/release-notes-ucc-2.0.html

If this error occurs again, please use "Clone This Bug".