Bug 31051 - UCS Installer screen refresh in XenServer
UCS Installer screen refresh in XenServer
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UCS Installer
UCS 3.1
Other Linux
: P5 normal (vote)
: UCS 3.2
Assigned To: Felix Botner
Moritz Muehlenhoff
: interim-2
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-13 11:30 CEST by Stefan Gohmann
Modified: 2013-11-19 06:43 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Flags outvoted after Product Owner Review:
Ticket number:
Bug group (optional): Usability
Max CVSS v3 score:


Attachments
XenServer UCS Installer (94.72 KB, image/png)
2013-04-13 11:30 CEST, Stefan Gohmann
Details
Screenshot of final confirmation (79.23 KB, image/png)
2013-08-12 12:31 CEST, Moritz Muehlenhoff
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2013-04-13 11:30:13 CEST
Created attachment 5169 [details]
XenServer UCS Installer

The UCS Installer does not always refresh the Installer screen during the
configuration. Sometimes you can't see the question, sometimes only some words
are missing. 

After pressing F12 and then F11 the screen is shown correctly.
Comment 1 Stefan Gohmann univentionstaff 2013-04-13 11:42:07 CEST
I'm not really sure if it is not a XenServer Console Bug. I've had the case that the installer was already started but I saw the boot message that the hardware is checked. After pressing F12 the installer stepped to the next screen.
Comment 2 Stefan Gohmann univentionstaff 2013-04-15 08:05:16 CEST
We should check this if we switch to the Debian installer.
Comment 3 Felix Botner univentionstaff 2013-07-04 16:32:57 CEST
In fact the problem seemed to be that there were too many screen refreshes. Every installer widget, curses pad (Hline, Button, ...) did a screen refresh.

According to http://docs.python.org/2/library/curses.html#curses.doupdate there is an alternative. Let every pad do a .noutrefresh (mark for refresh but wait) and than refresh the screen with curses.doupdate.

   "if you have to update multiple windows, you can speed performance and 
    perhaps reduce screen flicker by issuing noutrefresh() calls on all 
    windows, followed by a single doupdate()"

I replaced all "cursespad".refresh() in objects.py and main.py with "cursespad".noutrefresh() and added some curses.doupdate() (in draw_all(), in the  main loop, in help_win, act_win and activity, because they are not drawn in the main loop).
The XenCenter UCS installation looks fine now.

This needs to be tested intense, since basic things have been changed in the installer: 

 * normal mode
 * profile mode
 * are all widgets visible (help win, activity win, ...)
Comment 4 Ingo Steuwer univentionstaff 2013-07-29 09:51:40 CEST
I did 4 installations with XenServer with UCS 3.1 (realease version). In one case we didn't notice that the installation was already finished because the "final refresh" wasn't displayed...
Comment 5 Moritz Muehlenhoff univentionstaff 2013-08-12 12:30:50 CEST
I've made two installations and in both cases the final confirmation screen of the Installer wasn't properly updated: Some lines of the previous software selection screen are not overwritten and thus still appear on the screen.

See attached screenshot.
Comment 6 Moritz Muehlenhoff univentionstaff 2013-08-12 12:31:22 CEST
Created attachment 5364 [details]
Screenshot of final confirmation
Comment 7 Stefan Gohmann univentionstaff 2013-08-14 15:20:12 CEST
Wait until Felix is back.
Comment 8 Felix Botner univentionstaff 2013-09-12 14:38:02 CEST
(In reply to Moritz Muehlenhoff from comment #6)
> Created attachment 5364 [details]
> Screenshot of final confirmation

I could not reproduce this, all my ucs 3.2 test installations on xenserver were correctly displayed. (xenserver on xen11, virtual windows 7 with xencenter via virt-viewer)

But i fixed the profile based installation (the screen was not properly refreshed here).
Comment 9 Moritz Muehlenhoff univentionstaff 2013-09-19 11:05:15 CEST
Ok, I installed a system with the current 3.2 DVD  and I could not longer reproduce the visual glitch I saw back then.
Comment 10 Stefan Gohmann univentionstaff 2013-11-19 06:43:56 CET
UCS 3.2 has been released:
 http://docs.univention.de/release-notes-3.2-en.html
 http://docs.univention.de/release-notes-3.2-de.html

If this error occurs again, please use "Clone This Bug".