Bug 31130 - log umc server crashs
log umc server crashs
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 3.1
Other Linux
: P3 enhancement (vote)
: UCS 3.1-1-errata
Assigned To: Florian Best
Alexander Kläser
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-22 16:33 CEST by Florian Best
Modified: 2013-06-13 14:39 CEST (History)
4 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Cleanup
Max CVSS v3 score:
best: Patch_Available+


Attachments
crash.patch (622 bytes, patch)
2013-04-22 16:33 CEST, Florian Best
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2013-04-22 16:33:28 CEST
Created attachment 5182 [details]
crash.patch
Comment 1 Florian Best univentionstaff 2013-04-23 10:40:33 CEST
The same should be done for the script univention-management-console-module.
We had some crashes in the app center and UCS@School computerroom module which are more easy to track then.
Comment 2 Dirk Wiesenthal univentionstaff 2013-04-23 14:05:54 CEST
(In reply to comment #1)
> We had some crashes in the app center

May have been caused by a kernel trace. I patched univention-management-console-module and there was no traceback in the logs: The module segfaulted.
Comment 3 Florian Best univentionstaff 2013-06-04 11:04:58 CEST
The patch has been applied. The same has been implemented for UMC-modules.

UCS 3.1-1
univention-management-console (5.0.62-5)

UCS 3.2
univention-management-console (6.0.0-1)

packages built (3.2, 3.1-1)

YAML
2013-06-04-univention-management-console.yaml

Changelog created
Comment 4 Alexander Kläser univentionstaff 2013-06-08 16:21:34 CEST
The patch does not log any tracebacks in both cases.
In my tests I provoked a syntax error in univention/admin/syntax.py and raised an error in a module __init__() method.
Comment 5 Stefan Gohmann univentionstaff 2013-06-12 07:33:34 CEST
(In reply to Florian Best from comment #3)
> YAML
> 2013-06-04-univention-management-console.yaml

Please use 2013-05-29-univention-management-console.yaml which has not been released yet.
Comment 6 Florian Best univentionstaff 2013-06-12 16:19:24 CEST
(In reply to Alexander Kläser from comment #4)
> The patch does not log any tracebacks in both cases.
> In my tests I provoked a syntax error in univention/admin/syntax.py and
> raised an error in a module __init__() method.
Now also import errors are logged.

(In reply to Stefan Gohmann from comment #5)
> (In reply to Florian Best from comment #3)
> > YAML
> > 2013-06-04-univention-management-console.yaml
> 
> Please use 2013-05-29-univention-management-console.yaml which has not been
> released yet.
The YAML files have been merged.

univention-management-console 5.0.62-6.738.201306121615
Comment 7 Alexander Kläser univentionstaff 2013-06-12 16:34:19 CEST
3.1-1 Erratum
  Changes: OK
  YAML: With minor reformatting  → OK 

========================
  This erratum addresses the following problems:
  * The debug output is now explicitly flushed in order to prevent partial or
    missing lines in the log file.
  * UMC server and module crashs will now be logged.
========================

UCS 3.2
  Changes: OK
  Changelog: With minor adapdations → OK

========================
  Unexpected errors that caused \ucsName{UMC} server and modules to exit are now
  logged (\ucsBug{31130}).
========================
Comment 8 Janek Walkenhorst univentionstaff 2013-06-13 14:39:58 CEST
http://errata.univention.de/ucs/3.1/128.html