Bug 31318 - Static array reference in umc/widgets/MultiSelect
Static array reference in umc/widgets/MultiSelect
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 3.1
Other Linux
: P5 normal (vote)
: UCS 3.1-1-errata
Assigned To: Alexander Kläser
Dirk Wiesenthal
:
: 31418 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-08 14:53 CEST by Alexander Kläser
Modified: 2013-07-10 14:17 CEST (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:
klaeser: Patch_Available+


Attachments
Fix for member variable value in umc/widgets/MultiSelect (388 bytes, patch)
2013-05-08 14:53 CEST, Alexander Kläser
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kläser univentionstaff 2013-05-08 14:53:25 CEST
Created attachment 5216 [details]
Fix for member variable value in umc/widgets/MultiSelect

Occurred during work on Bug 31158, after reopening the exam module, values in
the MultiUploader from the previously closed module instance were still there.
The problem here is a static array reference for the
umc/widgets/MultiSelect:value. Other side effects than the current one are not
known, but possible.

The attached patch fixes this problem.
Comment 1 Alexander Kläser univentionstaff 2013-05-23 18:34:47 CEST
*** Bug 31418 has been marked as a duplicate of this bug. ***
Comment 2 Alexander Kläser univentionstaff 2013-06-18 16:25:25 CEST
Fixed for 3.1-1 Errata + 3.2. The YAML file as well as changelog have been adjusted accordingly.
Comment 3 Alexander Kläser univentionstaff 2013-07-02 15:11:37 CEST
YAML file: 2013-07-01-univention-management-console-frontend.yaml
Comment 4 Dirk Wiesenthal univentionstaff 2013-07-05 17:46:02 CEST
Maybe I misunderstood the bug. But the "Start exam" module still has the files selected when using it the second time. At least in FF 22. This should not be the case anymore, no?
Comment 5 Dirk Wiesenthal univentionstaff 2013-07-05 19:00:21 CEST
I do not see why this happens at all. Is it the very same module that was closed when opened again? Or is the wizard cached? Isn't this the bug?

In MultiSelect it says somewhere:
  if (!(this.value instanceof Array)) {
    this.value = []
  }

This is probably the reason why the behaviour did not changed. (But I did not go into detail here)
Comment 6 Alexander Kläser univentionstaff 2013-07-08 15:53:12 CEST
There was a static array reference in MultiUploader which needed to be fixed. Packages are building for errata and 3.2.


 univention-management-console-frontend (2.0.244-16) unstable; urgency=low
 .
   * Bug #31308: replace static array reference in umc/widgest/MultiUploader


 univention-management-console-frontend (3.0.14-1) unstable; urgency=low
 .
   * Bug #31308: replace static array reference in umc/widgest/MultiUploader
Comment 7 Dirk Wiesenthal univentionstaff 2013-07-09 16:56:37 CEST
Works
Comment 8 Moritz Muehlenhoff univentionstaff 2013-07-10 14:17:31 CEST
http://errata.univention.de/ucs/3.1/144.html