Bug 31382 - AppCenter does not prevent concurrent operations in same session
AppCenter does not prevent concurrent operations in same session
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - App-Center
UCS 3.1
Other Linux
: P3 normal (vote)
: UCS 3.1-1-errata
Assigned To: Dirk Wiesenthal
Felix Botner
:
: 29864 (view as bug list)
Depends on: 30611
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 23:40 CEST by Dirk Wiesenthal
Modified: 2013-07-05 15:41 CEST (History)
4 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Wiesenthal univentionstaff 2013-05-16 23:40:40 CEST
(In reply to comment #6)
> From Bug 30155:
> > Upon opening the module, the module should check for an ongoing installation,
> > and a progressbar should be prompted in that case.
> 
> This should be addressed via this bug, as well.

This needs to be done, 
if i start the agorum app installation and then close the browser, open the 
browser and logon to the UMC, i can open the appcenter module and start the
installation of another app (or agorum again), then weird things happen and i
end up with

-> apt-get -f install
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct
the problem.

+++ This bug was initially created as a clone of Bug #30611 +++
Comment 1 Dirk Wiesenthal univentionstaff 2013-05-16 23:57:10 CEST
Same session -> same process id -> locking mechanism fails.

Explicit check for running PackageManager added in:
  univention-management-console-module-appcenter 2.0.148-1.133.201305162348
and
  univention-management-console-module-appcenter 2.0.139-10.134.201305162350

Changelog, YAML updated

If a concurrent operation is noticed during App Center startup a progress bar is shown. If it is noticed just before a concurrent execution an error message is displayed. Note that the second progressbar is not very accurate as the information fetched from the server is divided by the number of concurrent app centers of the very same session. So some percentage infos may be missed. But it should work and is of course much better than a broken dpkg state.
Comment 2 Felix Botner univentionstaff 2013-05-17 09:57:46 CEST
No, still able to "install" another app after relogin (browser closed after i started an app installation). I think the second installation was terminated by the appcenter (because the first installation still runs and blocks the second installation) and the first installation runs just fine, but i got no error message, no progress bar no nothing?
Comment 3 Dirk Wiesenthal univentionstaff 2013-05-17 17:46:30 CEST
Yes, just a usability flaw. The App Center was not allowed to install something. But the error occurred too late, the response was already sent to the client.

Nevertheless, fixed in
  univention-management-console-module-appcenter 2.0.151-1.140.201305171739
and
  univention-management-console-module-appcenter 2.0.139-13.139.201305171736
Comment 4 Felix Botner univentionstaff 2013-05-21 10:54:41 CEST
OK - errata3.1-1
OK - yaml

OK - ucs3.1-2
OK - changelog
Comment 5 Moritz Muehlenhoff univentionstaff 2013-05-22 16:10:30 CEST
http://errata.univention.de/ucs/3.1/102.html
Comment 6 Dirk Wiesenthal univentionstaff 2013-07-05 15:41:36 CEST
*** Bug 29864 has been marked as a duplicate of this bug. ***