Bug 31643 - wrong apache startsite after system-setup-boot
wrong apache startsite after system-setup-boot
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: General
UCS 3.1
Other Linux
: P5 normal (vote)
: UCS 3.1-1-errata
Assigned To: Erik Damrose
Felix Botner
:
Depends on: 30624 30896
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 22:27 CEST by Ingo Steuwer
Modified: 2013-06-06 14:31 CEST (History)
4 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
management-console-module-setup.log (388 bytes, text/x-log)
2013-06-05 09:01 CEST, Ingo Steuwer
Details
setup.log (647.10 KB, text/x-log)
2013-06-05 09:01 CEST, Ingo Steuwer
Details
system-setup-boot.log (139 bytes, text/x-log)
2013-06-05 09:02 CEST, Ingo Steuwer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ingo Steuwer univentionstaff 2013-06-04 22:27:51 CEST
I've tested the EC2 Image in Ireland.

Bug in the image: the Apache start site is not set back to default:

root@ucs-master:~# ucr search site
apache2/startsite: univention-management-console/?module=setup\&username=root
 Path to the web server index page

samba4/join/site: <empty>
 Selects Samba 4 site for domain join

system/setup/prev/apache2/startsite: ucs-overview/de.html

-> the user is always forced to login to UMC as root


Bug in the documentation: the version information on the wiki quickstart is wrong
Comment 1 Stefan Gohmann univentionstaff 2013-06-05 06:25:26 CEST
The appliance setup wizard was not successful. Could you add the setup logfiles?
Comment 2 Ingo Steuwer univentionstaff 2013-06-05 09:01:26 CEST
Created attachment 5267 [details]
management-console-module-setup.log
Comment 3 Ingo Steuwer univentionstaff 2013-06-05 09:01:50 CEST
Created attachment 5268 [details]
setup.log
Comment 4 Ingo Steuwer univentionstaff 2013-06-05 09:02:09 CEST
Created attachment 5269 [details]
system-setup-boot.log
Comment 5 Erik Damrose univentionstaff 2013-06-05 16:49:24 CEST
This is actually a regression introduced by fixing Bug 31385, which was released as errata 117. This has to be fixed in another errata.
Comment 6 Erik Damrose univentionstaff 2013-06-06 12:20:26 CEST
Additional checks have been added. apache2/startsite will not be changed during an update on a joined system.

QA: check upgrade paths:
- 6.0.76-15 -> 6.0.76-17 (systems that did not install errata 117)
- 6.0.76-16 -> 6.0.76-17 (systems that installed errata 117)

ucs3.1-1-errata3.1-1
univention-system-setup (6.0.76-17)
2013-06-06-univention-system-setup.yaml

ucs3.2
univention-system-setup (7.0.0-1)
Changelog entry updated
Comment 7 Erik Damrose univentionstaff 2013-06-06 13:31:38 CEST
slightly updated version
errata3.1-1:
univention-system-setup 6.0.76-18.466.201306061324
yaml updated

3.2: 
univention-system-setup 7.0.0-2.467.201306061329
Comment 8 Felix Botner univentionstaff 2013-06-06 14:16:10 CEST
OK - errata3.1-1, ucs3.2-0

package not installed 
 joined
   -> not sets apache2/startsite
 unjoined
   -> sets apache2/startsite

package update from broken errata
 joined
   -> old package postrm undo apache2/startsite,
      new package does not set apache2/startsite
 unjoined
   -> old package postrm undo apache2/startsite,
      bew packages sets apache2/startsite

package update from previous versions
 joined
   -> old package does nothing postrm (ok here),
      new package does not set apache2/startsite
 unjoined
   -> old package does nothing in postrm (apache2/startsite still points to umc),
      new package does nothing because apache2/startsite already points to umc

OK - yaml

OK - Changelog