Bug 31713 - Changing CDs doesn't work
Changing CDs doesn't work
Status: CLOSED FIXED
Product: Univention Corporate Client (UCC)
Classification: Unclassified
Component: Hardware and device support
unspecified
Other Linux
: P2 normal
: UCC 1.0-errata
Assigned To: Felix Botner
Moritz Muehlenhoff
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 14:54 CEST by Jan Christoph Ebersbach
Modified: 2013-07-25 12:36 CEST (History)
4 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
Fix CD mount when changing CDs (1.88 KB, patch)
2013-06-11 14:54 CEST, Jan Christoph Ebersbach
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Christoph Ebersbach univentionstaff 2013-06-11 14:54:15 CEST
Created attachment 5272 [details]
Fix CD mount when changing CDs

When a user changes CDs in his drive, only the first CD was mounted properly.  All other CDs are not mounted, because the cdpinger daemon is killed when a CD gets ejected.

For non-USB CD drives Bug #31685 needs to be fixed first.
Comment 1 Ingo Steuwer univentionstaff 2013-06-14 15:16:12 CEST
A customer reported a bad performance while accessing CDs in a citrix session, please have a look at it i.e. during QA:
- it takes long until a CD appears in the citrix session (even if the user refreshes the Explorer)
- transfer rates are bad
Comment 2 Felix Botner univentionstaff 2013-06-17 14:56:36 CEST
fixed in ucc-errata for 3.1
Comment 3 Felix Botner univentionstaff 2013-06-27 10:37:27 CEST
added "cd" as valid device type in add_fstab_entry (univention-ucc-remote-mount)

-if [ "$ID_BUS" != "usb" ]; then
+ if [ "$ID_BUS" != "usb" ] && [ "${ID_TYPE}" != "cd" ]; then
Comment 4 Felix Botner univentionstaff 2013-06-27 10:41:29 CEST
(In reply to Felix Botner from comment #3)
> added "cd" as valid device type in add_fstab_entry
> (univention-ucc-remote-mount)
> 
> -if [ "$ID_BUS" != "usb" ]; then
> + if [ "$ID_BUS" != "usb" ] && [ "${ID_TYPE}" != "cd" ]; then

ignore this, wrong bug

 * added restart of cdpinger in remove_fstab_entry (univention-ucc-remote-mount) 
 * added code to speed up cdrom device (eject -x SPEED CDDEVICE) in 
   add_fstab_entry (univention-ucc-remote-mount) 
 * replaced udevinfo with udevadm in add_fstab_entry
Comment 5 Moritz Muehlenhoff univentionstaff 2013-06-27 12:48:30 CEST
I couldn't reproduce the original problem all the time (changing DVDs also worked for me with the old version in one case), but the new approach is correct and reliable.

The eject changes didn't improve the transfer speeds with my hardware, since the drive configured 24x speed in both cases, but since it did improve the transfer speed for the hardware rolled out internally we can keep it in. I couldn't test Citrix, since my XenApp setup doesn't work currently. If there's a delay between the time the drive is mounted under /run/drives and the availability in the Citrix session I'd rather suspect some internal polling delay in the Citrix client.

The yaml file is ok. I extended it with one more note.
Comment 6 Moritz Muehlenhoff univentionstaff 2013-07-25 12:36:01 CEST
http://errata.univention.de/ucc/1.0/14.html